Why does the form go blank after hitting "submit"?

  • Profile Image
    FbksChamber
    Asked on February 08, 2016 at 09:23 PM

    Good afternoon,

    We are a Chamber of Commerce and we recently switched to jotForm for our membership application. One of the people who tried to become a member contacted us saying they completed the form and it just went blank after hitting "submit". That happened to them twice. I tried the form from the user side, and it didn't create that problem for me. However, it did do that with a different form I filled out a few months back. 

    Is there a reason this happens? A browser we shouldn't use or an error in the form? Our forms are very important to us and we can't have that happening. 


    Please feel free to contact me at (907) 374-6703 with an answer to this. 

    I would appreciate your help on this matter.

    Thank you! 

  • Profile Image
    ashwin_d
    Answered on February 09, 2016 at 05:25 AM

    Hello FbksChamber,

    I did test your form and I am unable to replicate the issue you are having. I was ale to submit your form successfully without any issue. 

    I did check your webpage where you have embedded your form and it seems you have used your form's script embed code. I would suggest you to please embed your form using its iFrame embed code and see if that solves your problem. The following guide should help you how to grab your form's iFrame embed code:  http://www.jotform.com/help/148-Getting-the-Form-iFrame-Code 

    Do try it out and get back to us if the issue persists.

    Thank you!