Stripe Integration: Why payment is not being processed when the form is submitted?

  • Profile Image
    melodicsounds
    Asked on April 11, 2016 at 12:35 PM

    We have a prepopulated form: https://form.jotform.com/60967271989980 which fills with this: https://form.jotform.com/60967399364978 we are trying to do a payment and its not working... when you finish entering all details and you click "Envíar y Pagar" in the preview widget... it doesn't make the transaction and take you to Thank You page... wondering if this is a stripe problem or can you test it with a real transaction of $1 or .50$ or something like that?

  • Profile Image
    melodicsounds
    Answered on April 11, 2016 at 01:54 PM

    I am also getting "Oops amount must be at least 1000 centavo".

  • Profile Image
    Kevin_G
    Answered on April 11, 2016 at 01:57 PM

    I have checked your forms and noticed that the integration is working properly, I have checked the payment form and noticed that you are showing the payment field based on an input selection, such field is "Como quieres pagar?". 

    Upon checking your submissions I noticed that most of your submissions were sent selection "Efectivo" in the field "Como quieres pagar?", indeed, only one submission has been sent with "Pago en linea" selected. 

    This is the submission ID of that submission: 335940733641681296.

    Here is a screenshot where the payer info is shown:

    If you are still having issues, I would suggest you to check the integration and ensure that you have properly linked your Stripe account.