Connecting Jotform to zapier.

  • Profile Image
    Asked on May 12, 2016 at 11:56 PM



    I have been using Jotform with zapier for quiet some time and it was working normally before. then 2 weeks ago i encountered two problems without a reason, there problems are: 


    1- Jot was connected normally to zapier, and zapier can pull information such as the forms that I have. But after i select and test the form that zapier would pull data from the test comes in successful but the fields that zapier had pulled are only  (2)  and the codes are 

    Code : 401 Fields with no value: desc


    "EDIT: I have got a response from Zapier and they think it might be the API limit" 

    If you believe that is the case please let me know how can i fix that problem or if you can increase that limit.

    Please see the attached screenshot.

  • Profile Image
    Answered on May 13, 2016 at 02:02 AM

    Can you please confirm if this is the form that have the issue.

    I checked your account and I found only this form on it. The form currently do not have an existing submission data on it. 

    I think when you test the submission, that was the caused of error -- there was no data/submission that the Test procedure can detect.

    Try also redoing the integration process. Remove the existing integration and then reconnect it again to Zapier

    Let us know if issue is not resolve.

  • Profile Image
    Answered on May 13, 2016 at 03:25 AM


    And no that isnt the form, on my account i dont have forms that are working but I have shared forms from another account and those are the ones with the problem.


    take for example this form


    as for trying to redoing the integration i have done that a lot in hope of fixing it. I also moved the forms data from US servers to Europe and specified that in zapier too.

  • Profile Image
    Answered on May 13, 2016 at 04:10 AM

    Thank you for providing the details. I will test a clone of your form  also to check if I can reproduce the issue.

    I'll get back to you shortly.

  • Profile Image
    Answered on May 13, 2016 at 04:33 AM

    I was able to successfully do the test connection using a copy of your form.

    In my test process, I had to resolve the following conditions 

    1. Make sure ther is an existing submission


    2. In Advance Settings of my Zap account, I have to disable the SSL (I was having connecting Jotform which I am logged in using https)



    Please check also on your side if your settings complies to the 2 I mentioned. You can test again once you have setup.

    Let us know if you continue to have problem with the Zapier integration test.

  • Profile Image
    Answered on May 13, 2016 at 06:28 AM

    Hi and thank you for the thorough reply, you must have spent great effort doing that. Sadly I have tried to do the step you took and came back negative and with no change.

    I also asked Zapier to test the issue and they said all they can see is some API limit problem so i edited my post above to include that.

    Do you think an API limit can generate a 401 code? which i believe is unauthorized request.

    and if API limit is the problem what can i do to fix the issue.


    Thanks again

  • Profile Image
    Answered on May 13, 2016 at 08:47 AM

    On behalf of my colleague, you're kindly welcome. I've reset your API limit. We would appreciate it if you could also test it on your side and let us know the result. If this does not resolve the issue, please let us know and we will be glad to take another look.

  • Profile Image
    Answered on May 15, 2016 at 08:54 PM

    Hi and thanks for resetting my API, although after the reset  my jotform account stopped working all together and the error is  "API limit exceeded" 




    Please let me know if there is anyway you can help me fix this.

  • Profile Image
    Answered on May 15, 2016 at 10:42 PM

    I cloned your form and connected it with zapier. I was not able to replicate the issue that you encountered as I was able to successfully connect the form.

    I see that the form you are trying to connect is from another account. I have now reset the API limit of the aipp account. Please clear the form cache from that account and then try reconnecting jotform with zapier again.

    If the issue still persists, please let us know.

  • Profile Image
    Answered on May 17, 2016 at 10:05 PM

    Hi and thank you all for the support, It worked after the API limit reset.

    Now i am wondering if there is a way to increase the API limit so i wouldn't have this problem again
  • Profile Image
    Answered on May 17, 2016 at 11:09 PM

    Thank you for taking the time updating us on the status. Great to know it is working now.

    We will attend to your next question separately here