After submission is made and redirection started white screen is shown

  • Profile Image
    aperfectpocket
    Asked on May 18, 2016 at 11:37 AM

    Hi,

     

    We have been using your forms for over a year, that when you press the submit button the data goes through to a website to update.

    All has been good, but today it appears that when you now submit it shows a blank screen instaead of the success message. Plus the data is not getting through to the website system?

    We have changed nothing at all, when you try the form on a PC view it works all OK but through a mobile device, which we have to use it shows a blank screen.

    Could you please help and look in to it please as this vital top our day to day business.

    They are all the forms with EXCEL in the title URL of one of them is below.

    Thanks

    Colin

  • Profile Image
    Ben
    Answered on May 18, 2016 at 01:32 PM

    Could you please tell us if this is correct. All forms work over desktop / PC, but as soon as you try to submit them over a mobile device they fail to submit and show a blank page instead of the thank you message.

    Looking at the form and submitting it, I see that your form is redirecting to http://www.excel-environmental.com/app/appcall.php. The issues being that:

    1. the form is using HTTPS (secure connection) and you are redirecting to HTTP (unsecure). Many browsers might decide to block this, which is probably the reason why your mobile device is showing white / blank page.

    2. When I tried to go to the same I am not able to go there. It is showing me an error as server not found - if the first issue did not stop it, this one would probably cause issues.

    What I suggest is to check your server configuration and make sure that all the links that the forms are being redirected to are working properly and replace the ones that need to be replaced.

    Once you do, it should all start working again.

  • Profile Image
    aperfectpocket
    Answered on May 18, 2016 at 05:11 PM

    Ben, yes that is correct All forms work over desktop / PC, but as soon as you try to submit them over a mobile device they fail to submit and show a blank page instead of the thank you message.

    We have never had an issue before and all was working fine until about 10am today??

    When we try it on  pc it shows 'No server found' then you click refresh and it seems to work?

    Thanks

     

  • Profile Image
    Kevin_G
    Answered on May 18, 2016 at 09:00 PM

    I have tested your form and I'm being redirected to the same link http://www.excel-environmental.com/app/appcall.php which is showing "This site can't be reached" when it is loaded the firs time: 

    But if you reload it, it shows a MySQL error message and displays as shown below: 

    I would suggest you to fix this before to continue testing your form, once this is fixed if the issue still persists, please do get back to us and we will be glad to help you.