File Upload: Download links with "#" on file name breaks if they are clicked on an iPhone device

  • Profile Image
    Asked on May 31, 2016 at 08:38 AM

    Hi, I have the same problem, even though this solution doesnt'applies, since I'm able to open the attached PDF perfectly in the computer (W10 Pro), but not in my iphone (iOS 9.x).

    Any ideas? I even tried to login myself in the mobile, but it didn't work.


  • Profile Image
    Answered on May 31, 2016 at 08:53 AM

    I tried downloading your file uploads on your form submissions and I was able to download them properly. The original thread where you posted your question is about downloading file uploads getting XML access denied error message. Are you getting the same error message? If so, what specific submission?

    The form builder best works on a desktop or Mac computer, it would be quite hard to use the form builder if you are using a mobile device. However, you should still be able to download the file uploads on your submissions regardless of the device you are using. If you are able to download them using a Windows computer, then you should be able to download them to any device and OS.

    In iOS, I am not sure how files should be downloaded, I'm testing it right now and the PDF file is being opened in the browser itself, I am not sure if it is possible to download directly in iOS, unless there's an app for it.

  • Profile Image
    Answered on May 31, 2016 at 11:11 AM

    Hi Charlie, in the submission with date: 2016-05-30 16:04:38

    When I click on my Windows 10 the submission's generated e-mail for the URL of an attached PDF:

    Everything works fine, I can see the PDF in my browser.

    When I do the same in my iPhone, I get the XML access denied error... usually a PDF will be displayed in the default browser.


  • Profile Image
    Answered on May 31, 2016 at 11:29 AM

    I'm unable to replicate the problem.

    Here are some screenshots:

    iPhone 6S iOS 9:

    iPhone 6S Plus iOS 9:

    iPhone 5 iOS 6


    Samsung S6 Android 5 downloaded it automatically.


    I'm directly viewing this file upload link that you shared:

    Have you tried clearing your iPhone's browser cache? You can also ask another iPhone user to check that link. It seems to be specific on the device you are using, the device might be viewing a different file upload link?

    Have you tried using a different browser in iPhone? In my case, I'm using Safari on iPhones.

    We'll wait for your response.

  • Profile Image
    Answered on May 31, 2016 at 12:01 PM

    It works as a charm via the URL copied from my computer... but not from the original link included in the email, which is. Give me an e-mail, I'll forward it to you and you click on it... so you can replicate the problem ;-)

    PS: after clicking the link in the e-mail, it sends me here 

  • Profile Image
    Answered on May 31, 2016 at 12:25 PM

    I see, I think the problem is how the file link is being opened by your browser. 

    You can forward the email to, make sure to add in the subject line this "Thread 850409".

    The problem seems to be related to the file name of your file upload. In your case, the original file name and the link is this: 

    However, based from your end, it looks like this: 

    Noticed that it started to break after "OC", the file of that file is something like this "OC # APO16-00011418.pdf". The character after "OC" is a space which is %20 in character encoding. It's possible that your email or your device breaks the link on that character, which is why you are getting the broken link. 

    We'll wait for the copy of the email so that we can test it out.

  • Profile Image
    Answered on May 31, 2016 at 12:29 PM

    Hi Charlie, e-mail sent. Your explanation makes total sense. Would you consider we should teach our users not to use those characters? Is there a way to block those characters in the uploaded file's name? Or maybe it will be reported as a feature-request / bug? Just let me know! Thank you for your incredibly fast support.

  • Profile Image
    Answered on May 31, 2016 at 01:19 PM

    Thank you for the additional information. I was able to replicate the problem.

    It is indeed happening directly in iPhone, and only when you directly click the direct link. It's happening because of the character "#" on it.

    I'm not sure if this is a bug on iPhone or on our URL encoding, but I will forward this to our developers to have it checked, but I strongly advise that you copy the link and directly paste it on the browser address and see if that works as a temporary workaround.

  • Profile Image
    Answered on May 31, 2016 at 01:31 PM

    Great, thank you very much, I'll do like that and check often if it works ;-)