What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    How do I pass data from one form to another?

    Asked by sinatraman86 on June 07, 2016 at 10:39 PM

    I am trying to redirect users to another form based on responses to the initial form. I am also trying to pass some of the data on to the next form to spare the user some redundancy.

    I have read everything I could find on the forums and in the user guide for prepopulating fields, and I have come up with this url:

    https://form.jotform.com/61536130290144?pleaseEnter[month]={pleaseEnter:month}

    &pleaseEnter[day]={pleaseEnter:day}&pleaseEnter[year]={pleaseEnter:year}&asideFrom={asideFrom}&clientName[first]={clientName:first}&clientName[last]={clientName:last}&isTheGaurdian={isTheGaurdian}&gaurdianEmail={gaurdianEmail}&gaurdianName[first]={gaurdianName:first}&gaurdianName[last]={gaurdianName:last}&isTheClient={isTheClient}&clientEmail={clientEmail}

     

    This link is meant to be coming from: 

     

    https://form.jotform.com/61546182817157

     

    For some reason it is only working sporadically. I'm not sure if this has anything to do with trying to prepopulate hidden fields? 

     

    Thanks for your help!

    Page URL:
    https://form.jotform.com/61546182817157

  • Profile Image
    JotForm Support

    Answered by ashwin_d on June 07, 2016 at 11:10 PM

    Hello sinatraman86,

    I did check your form and found that you have added conditions to redirect users to thank you page. In one of the condition #22, the URL format is not correct and that could be the reason why this condition must not be working. You seems to be missing "?" in the URL. Please check the screenshot below:

     

    I have edited your condition and fixed it already. 

    I would suggest you to please test your form again and get back to us if you have any trouble.

    Thank you!

  • Profile Image

    Answered by sinatraman86 on June 08, 2016 at 09:45 AM
    Thanks for your quick response, ashen_d.
    This doesn’t seem to have fixed the problem. :(
    I’m actually trying to get condition #23 to work.
    Adam
    214-608-0701
    adam@adamcluchey.com
    ...
  • Profile Image
    JotForm Support

    Answered by EltonCris on June 08, 2016 at 11:21 AM

    There is also a problem with the link on condition #23, you have a space in the URL followed by =& symbol. This breaks the URL. It should only be & without the equal symbol and the space before it.

    Here's the corrected URL.

    https://form.jotform.com/61536130290144?pleaseEnter[month]={pleaseEnter:month}&pleaseEnter[day]={pleaseEnter:day}&pleaseEnter[year]={pleaseEnter:year}&asideFrom={asideFrom}&clientName[first]={clientName:first}&clientName[last]={clientName:last}&isTheGaurdian={isTheGaurdian}&gaurdianEmail={gaurdianEmail}&gaurdianName[first]={gaurdianName:first}&gaurdianName[last]={gaurdianName:last}&isTheClient={isTheClient}&clientEmail={clientEmail}

    Hope this helps!

  • Profile Image

    Answered by sinatraman86 on June 08, 2016 at 01:45 PM
    Thanks, I’ve made the correction. For some reason it’s still not working. One question specifically “Is the guardian available to sign?” isn’t getting passed to the second form. Could it have anything to do with being a conditionally shown field?
    Adam
    214-608-0701
    adam@adamcluchey.com
    ...
  • Profile Image
    JotForm Support

    Answered by Mike on June 08, 2016 at 03:59 PM

    I have removed two extra spaces from the redirect URL in condition #23.

    And also replaced {isTheGuardian} tag on the URL with the correct one {isTheGaurdian}.

    https://form.jotform.com/61536130290144?pleaseEnter[month]={pleaseEnter:month} &pleaseEnter[day]={pleaseEnter:day}&pleaseEnter[year]={pleaseEnter:year}&asideFrom={asideFrom}&clientName[first]={clientName:first}&clientName[last]={clientName:last} &isTheGuardian={isTheGaurdian}&guardianEmail={guardianEmail}&guardianName[first]={guardianName:first}&guardianName[last]={guardianName:last}&isTheClient={isTheClient}&clientEmail={clientEmail}

    Please let us know if the issue still persists.

  • Profile Image

    Answered by sinatraman86 on June 08, 2016 at 09:45 PM
    Thanks for such quick responses!
    Still not completely working. It seems like the radio button questions are the ones not populating.
    ...
  • Profile Image
    JotForm Support

    Answered by EltonCris on June 08, 2016 at 10:27 PM

    It is only populated when "Yes" option is selected in the radio button field but not the long "No...." option.

    Example, with sample data.

    This works:

    https://form.jotform.com/61536130290144?pleaseEnter[month]=01&pleaseEnter[day]=20&pleaseEnter[year]=2016&isTheGuardian=Yes

    This doesn't work:

    https://form.jotform.com/61536130290144?pleaseEnter[month]=01&pleaseEnter[day]=20&pleaseEnter[year]=2016&isTheGuardian=No, please send this form to the guardian for signature after I complete all other fields.

    I'm not quite sure but I think the dot and comma symbols are breaking the URL. If possible, I suggest to remove these two symbols on the radio button option. This might fix it.

    Hope this helps!