What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Required fields not showing up in email notifications for submissions

    Asked by browningreagle on July 18, 2016 at 11:34 AM

    For the form referenced in the link below, we've started getting submissions over the past several days, and the form has been acting a little quirky.  I made some adjustments, but I'm noticing that the email notifications I'm receiving for the submissions are not showing all of the info.

    I've had three submissions come through that do not have Phone Numbers listed, and the Phone Number field is required, so something had to have been entered.  I checked how the submissions appeared here on the site, but it's the same.  Are you all able to see anything behind the scenes? Like whether the person completing the form was actually able to submit without entering their number, or if they entered a phone number and it's just not showing up on the submission.

    Thanks!

    Form: https://form.jotform.com/61386211062144

    Submissions email notifications email in
  • Profile Image

    Answered by victor on July 18, 2016 at 01:09 PM

    When reviewing your form, I noticed that you did not have the REQUIRED enabled for the configurable list widget. Please enable this for the widget and let us know if that resolves the issue.

     

  • Profile Image

    Answered by browningreagle on July 18, 2016 at 01:16 PM

    Thanks Victor, I'll give that a shot.  I was pretty sure that I had previously tested it, and just having those two fields marked Required within the Configurable List widget seemed to be enough.

    I'll keep you posted whether the issue persists.  We've been getting quite a few submissions, so I should hopefully be able to figure it out by the end of the day.

    Thanks again!

  • Profile Image
    JotForm Support

    Answered by ashwin_d on July 18, 2016 at 02:20 PM

    Hello browningreagle,

    On behalf of my colleague, you are welcome.

    Do try out the suggestions and get back to us if the issue persists.

    Thank you!