What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    iFrame embedded form field names.

    Asked by woodlandgrp on September 20, 2016 at 07:54 PM

    I have a webpage built with the Beaver Builder WordPress plugin. It allows for an html field, this is what I put my iFrame embed code in. Not sure how or why, but my hidden field names have extra data. In the screen shot "label_26" input name="q26_utm_source". When I check my form it only has "utm_source" for the name. Any ideas how I can fix this?

    Page URL:
    http://www.cooleysrifttn.com/

    Screenshot
    form field iframe embedded name hidden iframe embed check
  • Profile Image
    JotForm Support

    Answered by liyam on September 20, 2016 at 11:00 PM

    Hello woodlandgrp,

    The prefix q##_ is used by the back-end processing for reference to the ID of the field. This should not be touched. I also made a test submission from a copy of your form and did not find any problems with it. But if you are experiencing some problems, please do let us know so we can have a look to address the matter.

    Thanks.

  • Profile Image

    Answered by woodlandgrp on September 21, 2016 at 11:46 PM
    When I tested this link: http://www.cooleysrifttn.com/?utm_source=facebook&utm_medium=post&utm_term=Log%20Home%20Package&utm_campaign=cooleys%20rift#contact
    The utm_source “facebook” did not show up in the hidden utm_source field.

    I’ve been using this method for the last 8 months with no issue. The only difference with this form is that I have conditional logic to check the “How did you hear” field and test for a selection. My logic first checks to be sure there isn’t already any data in the Source field before filling it out with the “how did you hear” data.

    You said you tested a submission and the utm variables work. Can you show me this test, like my attachement?


    Actually there is 1 more difference with this form, I’m using the Beaver Builder Wordpress Widget, but I pretty sure that isn’t the issue.

    Any light you can shed on this would be most helpful.

    - Jason Wofford

    ...
  • Profile Image
    JotForm Support

    Answered by Chriistian on September 22, 2016 at 01:59 AM

    The utm_source data might not be showing up in your submissions due to having conditions in the Source field. Your form Preferences currently has the Clear Hidden Values option to "Clear on Submit." This means any hidden field that has a condition will have their data cleared upon submission.

    To resolve this issue, you can simply set the Clear Hidden Values to "Don't Clear". By setting this option to don't clear, we are telling the form to not clear the data inside the hidden fields.

    If you need further assistance, please let us know.
    Regards.

  • Profile Image

    Answered by woodlandgrp on September 22, 2016 at 09:46 AM
    I made the change that you pointed out however, it’s not only not showing up upon submission, it’s not showing up at all. I have another JotForm on a separate site that is working as expected. I’ve included screen shots showing the hidden text fields. Here are the links I used:
    http://countrytracts.com/land-for-sale/tennessee/gated-community/?utm_source=Testing
    http://www.cooleysrifttn.com/?utm_source=facebook&utm_medium=post&utm_term=Log%20Home%20Package&utm_campaign=cooleys%20rift#contact

    I’m going to test the green form, the one in question, by removing all conditions. This is not ideal as I need those conditions to help sort the form but, other than that Beaver Builder plugin, this is the only difference in these two forms.

    - Jason Wofford

    ...
  • Profile Image

    Answered by woodlandgrp on September 22, 2016 at 09:46 AM

    Just for giggles I put the form on a website that is currently delivering other JotForms as expected, I also disabled the conditional logic. As you can see in the screenshot the problem persists. There is something happening with this form that is causing the problem.

    This is the link I used: http://www.countrytracts.com/delete-after-test/?utm_source=facebook&utm_medium=post&utm_term=Log%20Home%20Package&utm_campaign=cooleys%20rift#contact

    - Jason Wofford



    ...

  • Profile Image
    JotForm Support

    Answered by Chriistian on September 22, 2016 at 11:41 AM

    Hi,

    We were not able to see the attached screenshot that you have mentioned. Please attached the screenshot directly to this thread for further checking. You can check the thread here: https://www.jotform.com/answers/937591. To add a screenshot, please follow the instructions provided in this article: How to add screenshots images to questions to the support forum.

     

    I did some further checking on your form (http://www.jotform.us/form/62605062001136) and I noticed that the Source hidden field condition setup does not seems to work as expected. I cloned your form and did some testing and I noticed that the Source hidden field value is set to the condition momentarily and return back to empty value.

     

    To fix the issue, please try to remove the IF Source IS EMPTY rule in the condition setup. 

     

    Here is how the form will work with the new condition setup:

     

    You can also check this cloned form for further testing: https://form.jotform.com/62654639383971