Issue with attaching files on autoresponder

  • Profile Image
    Asked on October 18, 2016 at 03:16 AM

    I can attach an Excel file but when I receive the mail, it says the file is corrupted.

    I tried different versions of Excel file types.

    Using Chrome and Win7 for JotForm.

  • Profile Image
    Answered on October 18, 2016 at 03:24 AM


    I could not reproduce this problem.

    The excel file attached on autoresponder notification opened just fine for me.

    Maybe the file itself is already corrupted before you uploaded it in your autoresponder message?

    I suggest you check the files first and ensure that it is opening properly in your excel application before uploading it on your autoresponder notification. Jotform does not modify the attached files in any away so it should remain as it is when your users received them over email.


  • Profile Image
    Answered on October 18, 2016 at 04:01 AM

    Thank you for your instant answer!!

    There is something fishy in the file, indeed. I tried with another file with the same result, but all of a sudden a third file could be sent and received correctly. All the files behave normally, and have been share by e-mail with other people without trouble.

    I managed to correct the problem by simply copying the content of my original file, worksheet by worksheet, to the one I had working. Then I renamed it to the original, not-working one, and yes. Now it works!

    Strange, but wanted to document this if some other may have similar problems.


  • Profile Image
    Answered on October 18, 2016 at 04:09 AM


    As you have reproduced the resolving scenario, it is clear that the initial excel file had something wrong with it. Thank you for reporting such an issue as it should be helpful for some other users who may potentially have it too.

    Please contact us again if you need any further assistance. 

  • Profile Image
    Answered on October 19, 2016 at 02:37 AM


    I finally found the cause: The Excel file name contains scandinavian characters ("Sidosryhmä").

    Another little bug I realized: If you remove the file, and load the same file again, it does not actually load the file but uses a cached version of the file. Noticed that when I make changes to a file, remove & load it, the altered file is not uploaded, but the old version will be sent. When I change the file name, upload is ok. Happened also even there was another file uploaded in between the two with the same name but altered content.


    Thank you for your instant answers and quick support. Truly appreciate it!

  • Profile Image
    Answered on October 19, 2016 at 03:05 AM

    Thanks for providing the further details.

    Seems it is the issue of Browser's Cache. I would suggest you to clear Browser's Cache. Or try to check it in another Browser.

    If you still face the issue, or need further assistance, feel free to revert back.