What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Sometimes the form does not take user to the payment page, just says "Please wait" and nothing happens

    Asked by bakingfresh on October 20, 2016 at 02:48 AM

    Hello,

     

    I have had a few emails from my customers in the last month, at different times of the month, saying that when they complete the form and click "proceed to checkout" it then does not then take them to the paypal payment page. It just says "please wait".

    This has happened on and off through the last month. So I know sometimes the form works fine and sometime it does this.

     

    The forms I have had several emails from customers on this happening is:

    http://form.myjotform.com/form/62165234139554

    http://form.jotformeu.com/form/62662892620359

     

    Please advise because I am losing business over this.

     

    Many Thanks

    Page URL:
    http://form.myjotform.com/form/62165234139554

    payment page the form Emails please wait different
  • Profile Image

    Answered by Irshad on October 20, 2016 at 09:15 AM

    I have checked your both the forms, but I am not able to see any issue in the forms. 

    I also tried to make test submissions, and it successfully redirected me to Paypal. Please check the screenshot below:

    Form: http://form.myjotform.com/form/62165234139554

     

    Form: http://form.jotformeu.com/form/62662892620359

     

    Might be possible the glitch was because of some temporary technical issue, or Cache problem. I have also also cleared your Forms Cache. So please check it again, and if you still face the issue please let us know.

    Thank you!