Why have I stopped receiving copies of each submission by email?

  • Profile Image
    michaelcullen
    Asked on November 02, 2016 at 05:17 AM

    https://www.jotform.com//?formID=32873408085358

    I made a couple of changes to the Thankyou page yesterday and since then I no longer receive copies of each submission by email. They should be sent to michael@i-escape.com and nadine@i-escape.com - please can you check / fix and let me know?

  • Profile Image
    seth
    Answered on November 02, 2016 at 08:05 AM

    Hello,

    I check your email notification recipients. These email addresses are not in the bounce list.

    I checked mail logs. You can also view your mail logs from history under account page:

    As you can see from the log, you are receiving emails from submissions. However, JotForm has email issues recently. Our emails fall into spam boxes. Could you please check your spam box and mark these emails as not spam?

    If you can't find the emails in your spam/bulk folder please contact us again.

    Thank you.

  • Profile Image
    emucoe
    Answered on November 02, 2016 at 10:08 AM

    I, too, have noticed that e-mail messages *appear* to have been sent, according to the mail history, but they do not always show up. I checked Gmail's junk mail, and the messages are not showing up there, either. I tried the directions for using our own SMTP settings, but then outgoing mail all failed - even after the setup/test worked.

    What do you mean by this statement: "However, JotForm has email issues recently."? If you know you have issues, why not notify the community? For some of us, forms are critical to our daily workflow. To randomly discover there might be problems, is truly disappointing.

  • Profile Image
    Michael Cullen
    Answered on November 02, 2016 at 11:28 AM

    Thanks for your answer.

    The missing emails are not in my spam folder.

    But I made another test submission just now and it arrived by email.

    Have you done something to fix it?

  • Profile Image
    BDAVID
    Answered on November 02, 2016 at 02:41 PM

    Our developers have fixed the issue, please inform us if this continues again.