Form won't submit

  • Profile Image
    macpooh
    Asked on December 10, 2016 at 08:53 PM

    I have used these forms a few years ago on a pure html website and they worked fine.  We have resurrected these same forms but have embedded them in a new WordPress site using this embed code:

    [embed]https://form.jotform.com/form/31205278207953[/embed]
     
    The form appears on the page as it should.  The fields and hovertext behave as they should.  But when the submit button is clicked, it just displays "Please Wait".  It never returns the thank you page or an external link.  Nor does it submit the inputted data.  It just freezes.
     
    After looking on the forum for anyone else who had experienced this problem, I added your embed plugin for WordPress.  It did not work at all.  The icon was visible in the editor but it did nothing.  Before you blame plugin conflict, I disabled every plugin EXCEPT JotForm's and it still did not work.  All plugins being disabled did not change the form submission problem either.
     
    Another reason I don't believe it has anything to do with our site is that I am using another company (Worldsoft Business Suite) for the contact form.  It is embedded code calling out to a server just as Jotform does.  Its form processed with no problem and returned a result.
  • Profile Image
    BJoanna
    Answered on December 11, 2016 at 04:26 AM

    I have tested your embedded form and I was able to replicate mentioned issue. Submit button was stuck on "Please Wait...".

    Please try to re-embed your form with iFrame code. This should resolve your issue. Inside of this guide you can find how to get iFrame code of your form: 

    https://www.jotform.com/help/148-Getting-the-form-iFrame-code 

    Hope this will help. Let us know if you need further assistance.