JotForm 4 Problem -- Can't Edit HTML Text in Form Created in V3

  • Profile Image
    tamsyn
    Asked on March 24, 2017 at 12:38 PM

    Hi there JotForm Staff,

    I'm giving JotForm 4 a try again, thinking I'd try it out modifying a form I created last year in JotForm V3.

    In that form (https://www.jotform.com/build/70824524114146 -- now titled "Field Day Host Outreach & Ideas") -- I can't edit af "free-text" block (the very first one, starting with "2016 Field Day Host Bio and Media Form") that had been created in V3 with the HTML text feature.

    However, I cannot get into that field to edit.

    I did a search on the forum, and looks like other people have had this problem too. I'm using the latest version of Chrome.

    Thanks for your help,

    tamsyn

  • Profile Image
    BJoanna
    Answered on March 24, 2017 at 04:10 PM

    I have inspected your form and it seems that you were able to resolve your issue. 

    Text "2016 Field Day Host Bio and Media Form" is changed to "Field Day Host Outreach Preferences & Ideas Form". 

    I saw that you are currently using Version 3, so I assume that you have edited your form using Version 3. 

    I have also cloned your form, but I was not able to replicate mentioned issue in Version 4. I was able to edit test field. I have also used Chrome. 

    I have cleared your form cache. Please try again with Version 4. You can also try to use some other browser. 

    If the issue still persist in Version 4, please let us know.

  • Profile Image
    SFSadmin
    Answered on March 27, 2017 at 11:18 AM

    I ran into the same problem. A quick fix that worked for me was to switch back to Jotform v3, make the edits, and then return to v4.

  • Profile Image
     
    Answered on March 27, 2017 at 01:05 PM

    Hi BJoanna,

    Thank you for looking at my form issue! I did switch back to V3 to make my edits, after I had problems in V4 -- but I just went back and tested the form again in V4 and I *was* able to edit the HTML field now.

    It must have been the form cache issue, as originally, I was neither able to double-click into the HTML field to edit nor did any controls pop up on the top-right, as shown in your action video.

    However, that issue, at least, appears to be resolved now -- but there are a couple of other quirks, which I'll ask in a new thread.

    Thanks again!

    tamsyn

  • Profile Image
    BJoanna
    Answered on March 27, 2017 at 02:41 PM

    I am glad to hear that your issue is resolved. 

    Feel free to contact us if you have any other questions.