What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Autoresponders not being sent out.

    Asked by ywamepjcomm on June 28, 2017 at 03:18 PM

    I don[t get any autoresponders from my form.

    Page URL:
    https://www.jotform.com/build/71296982947172

  • Profile Image
    JotForm Support

    Answered by Mike_G on June 28, 2017 at 05:35 PM

    I have checked your form and I see that the email alerts are set to be sent conditionally. There are multiple email autoresponders in your form, may we know which of these autoresponders are you having issues with, please? Since you are trying to send the autoresponders conditionally, it is possible that the issue is with how the conditions are set. Can you also check if the field name (unique name) of the email field in your form match the one that is in your condition, please?

    Related Guides: 

    How-to-Find-Field-IDs-and-Names

    How-to-Send-Email-Based-on-User-s-Answer

  • Profile Image

    Answered by ywamepjcomm on June 28, 2017 at 06:04 PM

    Yes, I have multiple Autoresponders, six of them actually. ALL of those autoresponders are not received at least in the email recipients. I know I set them out to be sent conditionally (which I do in one form that I just created and works fine -https://form.jotform.com/41767741377970- What I want to say with that, is that they work in that form but not in this one... I have check  to make sure that I chose the Email recipient correct, in this case I have only one in my form, and is the yourEmail10... so, in the Recipients tab I chose Your E-mail

    Again I have checked the conditions of all those autoresponders (that actually are very close to the conditions related to the notifications, so I don't think that is the problem, maybe I am wrong, but I have checked that and didn't find any mistake there... BUT I AM NOT THE EXPERT, YOU GUYS ARE!... So please check that out...

    If you see all my conditions, you will see that the conditions are:

    Applicant chooses one option of field "What are you interested in?|"

    Continues filling out my form.

    Submits form.

    A Notification is sent out to us (based on conditions). This works fine in all my notifications/conditions.

    An Autoresponder is supposed to be sent out to the applicant (based on conditions), but this is the part that does not work work right now, and ALL the conditions have the same problem.

     

    Thank you for your help.

    David

  • Profile Image
    JotForm Support

    Answered by Kevin_G on June 28, 2017 at 08:44 PM

    I have tested your form directly and I could see the issue, I can see the email does not appear in the email log either; however, after further inspecting the form as well as your conditions I found that the field name used is not correct. 

    This is the actual field name of your field: 

    Please, update the field name in your conditions as well, the emails should be working fine after this is updated. 

    This guide will help you finding the field name: https://www.jotform.com/help/146-How-to-Find-Field-IDs-and-Names 

    Hope this helps. 

  • Profile Image

    Answered by ywamepjcomm on June 30, 2017 at 01:59 PM

    Yes, that was the problem, I changed the name field to yourEmail10 and it worked.

     

    Thank you for your help

     

    David