Form fields are not displaying input data as we type in

  • Profile Image
    LSAR
    Asked on July 30, 2017 at 08:10 PM

    I used a template form, then went in and modified it to suit my needs.  I sent a test email to myself.  When I published it, then went in to the form itself (as a random user would), it would not let me enter data in many fields, and those it did let me enter in, I could not see what I was typing.  This is my first time doing this, so I was unable to determine and correct the problem myself.  

  • Profile Image
    ashwin_d
    Answered on July 30, 2017 at 11:51 PM

    Hello LSAR,

    I'm sorry for the trouble caused to you. 

    The issue is caused because of the font color you have set for textboxes. Please inject the following custom css in form and that should solve your problem:

    .form-textbox, .form-textarea {

        color: #060606 !important;

    }

    The following guide should help you how to inject custom css code in form: https://www.jotform.com/help/117-How-to-Inject-Custom-CSS-Codes

    Hope this helps.

    Do get back to us if you have any questions.

    Thank you!

  • Profile Image
    LSAR
    Answered on July 31, 2017 at 01:43 AM
    Hello,
    Thank you for the prompt reply. I went in and did as you suggested (see
    screenshot below), but to no avail. I also went in and made the font color
    black on a plain white background and tested it again, but it still doesn't
    work. What do I have still have wrong? Thanks.
    Natalie
    [image: Inline image 1][image: Inline image 2]
    ...
  • Profile Image
    ashwin_d
    Answered on July 31, 2017 at 03:30 AM

    Hello LSAR,

    The custom css code which you have injected had some special character and because of which it was not applied. I have gone ahead and solved this problem in your form. Please check the screenshot below:

    I would suggest you to please test your form again and get back to us if the issue persists.

    We will wait for your response.

    Thank you!

  • Profile Image
    LSAR
    Answered on July 31, 2017 at 12:43 PM
    I just tested it out and it worked! Thank you very much for the
    assistance! I apologize as I didn't realize there was an extra character
    in there and this is my first foray into trying anything of this kind.
    Again, I appreciate the prompt reply!
    Natalie
    LSAR
    ...
  • Profile Image
    LSAR
    Answered on July 31, 2017 at 01:44 PM
    Ok, scratch that. It did work earlier. I went in and started to create a
    new form by cloning that form (new form is Owner Surrender Form). I got it
    all built, then previewed it to test and it's got the same problem. I went
    back to the Foster App Form to copy over the CSS to the Owner Surrender
    Form and now that one is not working either! I thought by cloning it to
    start a second form, it would leave the first form untouched. I think the
    ...
  • Profile Image
    Mike
    Answered on July 31, 2017 at 04:02 PM

    I have checked the Owner Surrender Form and looks like the special characters were there.

    So I have removed them to fix the issue.

    In Firefox and Google Chrome it should be possible to use Ctrl + Shift + V (Paste Plain Text) combination to paste the text content without formatting.

    If you need any further assistance, please let us know.

  • Profile Image
    LSAR
    Answered on September 21, 2017 at 10:43 PM
    Hi. I went to your site and saw the note that the missing email
    notification issue is being addressed currently. My question is if we will
    get those notifications once the glitch is fixed or if there is an easy way
    to resend them to our specified email address? Thanks!
    Natalie
    *Lone Star Aussie Rescue*
    ...
  • Profile Image
    EltonCris
    Answered on September 22, 2017 at 01:25 AM

    Yes, you will receive the emails. They are only delayed.

    No emails will be lost.

    Thanks

  • Profile Image
    LSAR
    Answered on September 22, 2017 at 10:43 PM
    OK we received one delayed email from our foster application forms and one
    real time today from the same form, but there is still one missing email
    from an adoption application submission from yesterday. Are all the
    glitches fixed at this point to where it should have come through?
    Thanks.
    Natalie
    ...
  • Profile Image
    jonathan
    Answered on September 23, 2017 at 01:26 AM

    The last question was about a different feature. We will resolve it on another thread here https://www.jotform.com/answers/1255657

    Thanks.