Nothing is happening when I click submit on my form

  • Profile Image
    NNWestcffd
    Asked on August 17, 2017 at 12:31 PM

    For our event "Faith Formation Day 2017," when people click "submit" nothing happens. Very briefly a message appears at the bottom saying there's an error on the form and it has to be fixed but it stays for about a millisecond. But still nothing happens. And none of of the appointment widgets are keeping count either. We need this fixed ASAP for the event is Saturday. 

  • Profile Image
    AIDAN
    Answered on August 17, 2017 at 12:49 PM

    I have created a clone of your form in an attempt to replicate your issue, to no avail:

    Here is my cloned form: https://form.jotformpro.com/72284826709971

    What I suggest to you is to click on the widget settings of each of the appointment slots you have in your form, then click save, so that you refresh their configuration. That should solve any issues with them as they seem to be the elements that are preventing your form from working properly.

    I hope this helps. If you need further assistance please let us know. Thank you.

  • Profile Image
    NNWestcffd
    Answered on August 17, 2017 at 01:02 PM

    I just did and it still won't work

  • Profile Image
    AIDAN
    Answered on August 17, 2017 at 01:16 PM

    Could you please test my cloned form to see if that works for you? Here is the link again: https://form.jotformpro.com/72284826709971

    Also, could you please clone it and see if the resulting cloned form in your account works as expected?

    Here is our guide on how to clone an existing form from a URL: https://www.jotform.com/help/42-How-to-Clone-an-Existing-Form-from-a-URL

    Thank you in advance and apologies for any inconvenience.

  • Profile Image
    NNWestcffd
    Answered on August 17, 2017 at 01:19 PM

    I just tried yours and it worked. But when I cloned mine and tried to register on the cloned one on my account, the same problem happens. 

  • Profile Image
    BDAVID
    Answered on August 17, 2017 at 01:36 PM

    After cloning the form, make sure to update all widgets:

    Then clear your forms cache: https://www.jotform.com/help/229-How-to-Clear-Your-Form-Cache 

    Let us know if that helps.

  • Profile Image
    NNWestcffd
    Answered on August 17, 2017 at 05:33 PM

    Yep, just did both of those. It still won't work. 

  • Profile Image
    BDAVID
    Answered on August 17, 2017 at 07:49 PM

    I cloned your form, and made sure it worked on my end, then I moved it entirely to your account, and did a second test to make sure it still works. 

    So, you may test it as well: http://www.jotformpro.com/form/72288011480957 

    You will find it in your account as "NEW Faith Formation Day 2017 - Online Registration".