Squarespace Embedded Form: After navigation to web page with form, the form iframe is blocked

  • Profile Image
    dayleylayne
    Asked on November 04, 2017 at 12:34 PM

    Hi, I recently added a patient registration form to my squarespace domain however, the form itself is not showing up in full version. Only the first section containing general information appears and there is no way to scroll through the rest of the form. 

    I copied and pasted the code meant for squarespace users, but this is the result.

    Can you please help me?!

  • Profile Image
    TREVON
    Answered on November 04, 2017 at 02:08 PM

    Thank you for contacting us. I have tested the form from my end and I could not replicate the same error. I have also tested the url on Mac OS and could not replicate the issue.

    1509818850Link on Safari Browser.gif

    Would you kindly try clearing your browser cache and confirm if the same issue re-occurs.

    Also would you kindly try accessing the URL using a different Browser like Chrome or Firefox.

    If you still experience the same problem kindly try to re-embed the form again to squarespace.

     

  • Profile Image
    dayleylayne
    Answered on November 04, 2017 at 06:43 PM
    What the heck!! I've had two other people try on their devices and they
    have no scrolling option either. I'm not sure what is going on. I've
    re-embedded it multiple times. I will try again though.
    ...
  • Profile Image
    Mike
    Answered on November 04, 2017 at 10:13 PM

    I was able to reproduce the issue by opening the https://dayley-harper.squarespace.com link in a private browser window and then clicking on the Forms menu item. The issue may be somehow related to the way how the page content is loaded by the Squarespace website. The issue is not happening when you directly visit the https://dayley-harper.squarespace.com/forms/ link.

    Please do a test by embedding your form using a standard embed code.

    Let us know how it goes with the standard embed code.

  • Profile Image
    dayleylayne
    Answered on November 04, 2017 at 11:40 PM

    Hi! Thank you for looking into this, I really appreciate it.

    Using the "Embed" to directly apply the link, results in the form disappearing altogether and being replaced by one line of text that reads "Script Disabled".
    What does this mean?
  • Profile Image
    dayleylayne
    Answered on November 04, 2017 at 11:43 PM
    Hi! Thank you for looking into this, I really appreciate it.
    Using the "Embed" to directly apply the link, results in the form
    disappearing altogether and being replaced by one line of text that reads
    "Script Disabled".
    What does this mean?
    ...
  • Profile Image
    Nik_C
    Answered on November 05, 2017 at 03:53 AM

    I checked your website but I wasn't able to see the "script disabled" error there, I see that there is a link to a popup of your form:

    1509871663screencast.gif

    Would you mind re-embedding your form by using the Squarespace embed method: https://www.jotform.com/help/37-Adding-a-form-to-Squarespace so we can test this issue further.

    Thank you! 


  • Profile Image
    dayleylayne
    Answered on November 05, 2017 at 01:22 PM

    I've revised the format to do just that! Instead of having the form live and embedded, I created a link that opens up instead - kind of fixed the issue!

    Thank you so much for your help.

  • Profile Image
    Mike
    Answered on November 05, 2017 at 06:19 PM

    Thank you for your update. The form should work properly with your workaround.

    Unfortunately, this is still not clear to me why the form script is not being processed properly in some cases when the page is accessed by the relative link like /contact. I have tried to create a sample squarespace page to include into a bug report ticket, but on my own squarespace trial website everything worked properly.