Registration Issues, inability to submit the form.

  • Profile Image
    Destinylittle
    Asked on February 08, 2018 at 10:30 AM

    Hello, I have registrants who have not been able to submit their registrations. 

    They are able to pull up the link and to enter in all their information, but when they hit submit it just says please wait and does not submit the form. 

    When I register them it works fine, do you know what would cause this? they have tried registering in different browsers with the same problem. 

    thank you for your time, and help with this matter.


    Destiny Little 



  • Profile Image
    Nik_C
    Answered on February 08, 2018 at 11:43 AM

    We're sorry for this inconvenience.

    Could you please tell us is this happening when your users access the form directly or is your form embedded in a website?

    Also, if the issue is happening to several users only, it would help if you could get the console report from them, here is how https://www.jotform.com/help/453-How-to-get-a-console-report-from-most-common-browsers, that should help us determine the cause.

    We'll wait for your response.

    Thank you!

  • Profile Image
    Destinylittle
    Answered on February 08, 2018 at 12:43 PM
    Thank you for your response, they are using the link to access the site. It has happened to 3 users so far and I will try to obtain that information from the users.
    Thank you
    ...
  • Profile Image
    Nik_C
    Answered on February 08, 2018 at 12:47 PM

    Please do, and if it is possible please share the link to the site where the form is embedded.

    Thank you!