Spreadsheet to Form Widget

  • Profile Image
    AgilityAssoc.Canada
    Asked on March 26, 2018 at 08:48 PM

    On form 80704754652964 I am using Spread to Form Widget. I had tested it last week with great success. Today I get a note from a user telling me that it would not work. After checking I was able to replicate the problem. I then deleted the csv file and uploaded it again. Now it works fine. I really don't want to have this become a task I have to do frequently. This concerns me, I have to be able to trust that the widget will work consistently.

    This is a great tool and it will save the Trial Applicants a lot of time filling the form.

    Can you please offer an explanation as to why I had to delete then upload the csv file.  

    Best, Robert

  • Profile Image
    tina
    Answered on March 27, 2018 at 03:29 AM

    Sorry for the inconvenience caused to you.   

    I was not able to replicate this issue too. Nevertheless, some browser console screenshots will be helpful to understand the issue more clearly.

    1522135738newbe.gif

    -> Could you please ask your form user who has faced with the issue, to send some screenshots of the browser console if they see any errors on the console.

    -> Could you please ask your form submitters which browser they used when the issue occurred? (browser name and version number)

    ->Please be sure that your browser extensions don't block our widgets server.

    This link might be helpful for the form users who have faced this issue to report the errors:

    How to get a console report from most common browsers?

    We will wait for your response. 

  • Profile Image
    AgilityAssoc.Canada
    Answered on March 27, 2018 at 09:50 AM

    One thing to be aware of, I was able to replicate the problem that she was having that is until I replaced the csv file. After I uploaded a new copy of the file the problem was resolved for me.

    After notifying her that the problem appeared to be resolved she tried to use it many more times without success. I discovered she is using a MAC and Safari. I cannot install Safari on my PC and have it work properly so I could not test it with Safari browser.  It works on FireFox. She also has a PC and said she would try using Chrome later today and let me know. 

    I just tried it on my wife's MACbook Safari and it worked successfully. I am going to advise my user that it will work on a MACbook. She may have to clear the Safari browser cache.

    Are you aware of any issues with this widget when using Safari? 

    This actually appears to be two separate issues.

    1. csv file became corrupted and had to be reloaded.

    2. One of my users is having difficulty using the form in Safari.

    Number 1 was my main concern when submitting this ticket.

    Thank you, Robert

  • Profile Image
    AgilityAssoc.Canada
    Answered on March 27, 2018 at 04:42 PM


    I don't understand this statement: If question is my OS, I'm using Win 10 Pro. 10.0.16299.309.


    This is highly unlikely bit depending on OS of the machine there might be chances the CSV may be corrupted



    I have not been able to replicate the problem on Safari also.

    This particular user is very busy and has not had a opportunity to do any further testing. She advised she is using the latest version of Safari and issue is likely cache. She has told me not to concern myself with her problem, she will resolve it. 


    I did receive a test submission from another user, unknown, that worked perfectly. 

    SO, my question still is, why did the csv file fail and I had to replace it.

    Best, Robert



  • Profile Image
    Adrian
    Answered on March 27, 2018 at 06:02 PM

    Hi Robert,

    From what I can read here, the issue was resolved by reuploading the CSV file.

    I am not sure why you had to do this but I am guessing that the CSV file could have been inaccessible or the widget had a misconfiguration.

    In any case, this should not happen again as long as you do not remove the file from the widget or edit the widget configuration.

    Let us know if this happens again and we will look further into the issue.

    We are sorry for any inconvenience.

  • Profile Image
    AgilityAssoc.Canada
    Answered on March 28, 2018 at 09:37 AM

    Hi, Thank you for the response. If it occurs again I will be in contact. Best Regards, Robert