form field be blanked after edit submission

  • Profile Image
    bluefiregroup
    Asked on March 28, 2018 at 02:41 AM

    UPDATE - SAME PROBLEM - new field

    I think I am cursed!
    I am wondering - did Jotform make a collection of adjustments in the last 12 to 18 months...? This form was working brilliantly for the last 2 years. But now it seems to have problems after some very minor adjustments I made a month or so ago. It's almost as if when I edited the form, it triggered an update of the form system to a new version or something like this (I am pretty certain I was using the OLD editing form-builder method when this form was working correctly..)

    I am seeing exactly the same problem as previously reported, but with a new field.
    Here is the form (without the fields discussed above)

    https://form.jotform.com/bluefiregroup/website-requirements

    The problem field is the last one on page-1

    1. The last field on page-1 is "Select Your theme". I choose Cornwall. Click NEXT
    2. Page-2 now requires that you Check "confirm choice of this theme"
    3. Skip to end and SAVE+ EXIT

    Now "Edit Submission"

    The foot of page-1 now displays a new field saying "Your Selected Theme is:"
    And it should say "Cornwall" in red.
    But again, I am seeing it flash up - (in red as this is read only)
    And then get blanked out

    See below - I Edit Submission .. then scroll down very fast to that field - you will see it quickly flash in red and then blank out...

    15222115602018-03-27_22-31-58.gif

     

    I tested on chrome and Edge and Firefox. On chrome I am logged out and cleared the cache to remove old javascript etc.

    Here's my theory...: 
    There is a condition - just like in the earlier reported issue - that looks at the "Select Your Theme" field - and "if filled", copies this to the "Your Selected Theme is:" field.
    It seems to me that the IF statement checking STATE = ...  is generally not working. In the previous situation, and this one, it was STATE = IS FILLED
    But I did change that to be prefilled with a character 'X" and change the test to be "is not equal to "X"... but it didn't make any difference.

    This is the second time on the same form where this condition seems to be failing or causing this corruption.
    In the first case, as mentioned above, I have actually deleted the IF statement and created a workaround. But in this case I need this to work.

    Looking forward to hearing any ideas on this!

  • Profile Image
    tina
    Answered on March 28, 2018 at 04:06 AM

    Please allow me some time to test this issue and I will get back to you as soon as possible.

    Thanks!

  • Profile Image
    tina
    Answered on March 28, 2018 at 03:22 PM

    The issue about IS FILLED statement worths to investigate and I am still testing this issue in order to detect the actual problem. However, I would like to suggest you a workaround which might cover your needs for now.

    First, I would like to recommend you to find  "Clear Hidden Field Values" section under Form settings and select "Don't Clear" option in order to prevent deletion of the values of the hidden fields on edit.

    1522264928Screen Shot 2018-03-28 at 10.0


    Also, I have cloned your form and make some changes on condition which is related to selected theme field.

    I have changed this condition:1522264207Screen Shot 2018-03-28 at 10.0

    to this:

    1522263944Screen Shot 2018-03-28 at 10.0

    What I have done is considering all the possible values of the "Select Your Website Theme" if it is equal to one of the dropdown items and finally passing its value to "Your Selected Theme is" field.

    I have tested the form with this way again and wasn't able to reproduce the issue so far.

    1522264543ttt.gif

    Could you please test and let us know if the issue is solved or not?


    demo form:

    https://form.jotform.com/80865882526974

  • Profile Image
    bluefiregroup
    Answered on March 28, 2018 at 06:54 PM

    Hi Tina - just changing the "Clear Hidden Field Values" section under Form settings and selecting "Don't Clear" option has fixed the issue. I made no other changes.

    So, the [Select your Website Theme] field, which, once we have made a selection is conditionally HIDING that field, is now not NOT going to be cleared when the form is saved.

    .. so, when the submission is edited again - the IS FILLED condition is getting executed and re-inserting the selected value into the [Your Selected Theme is] field - so everything looks good.


    I think this re-enforces the theory that the IS FILLED condition is not executing correctly.

    As described above it works fine when the field is filled with value - i.e. the IS FILLED is true.

    But, the opposite is where the error lies. When the field is NOT FILLED - ie BLANK or EMPTY - the IS FILLED is mistakenly thinking the field is filled.

    So, we have an operational from again - thank you - but I think that this does still need looking at.

    Please do let me know if this issues is identified and does get resolved

    thanks!

  • Profile Image
    Mike
    Answered on March 28, 2018 at 10:18 PM

    I think this re-enforces the theory that the IS FILLED condition is not executing correctly.

    As described above it works fine when the field is filled with value - i.e. the IS FILLED is true.

    But, the opposite is where the error lies. When the field is NOT FILLED - ie BLANK or EMPTY - the IS FILLED is mistakenly thinking the field is filled.

    Is there any way that you can create a simple form that is affected by that bug?

    We can escalate a ticket to our developers, but we need a clear example where the condition does not work.