Ticket Purchases widget not working

  • Profile Image
    lorbbyo
    Asked on August 07, 2018 at 07:01 PM

    Hello,

    I am using the Ticket Purchases widget on my form but am having some trouble.

    1) The ticket type options are appearing cut off on my form (you can only see the first option and half of the second option).

    2) When I set the field to "required" it gives the user an error saying "This field is required" even when a ticket type is selected.

    Any help you can provide is greatly appreciated.

  • Profile Image
    Jan
    Answered on August 07, 2018 at 10:21 PM

    I checked your form and I can see the Ticket Purchase widget option is showing properly. Here's a screenshot:

    153369434908-08-2rx4u.png

    I suggest you increase the width of the widget to "560". Just click the "Properties" icon and you will see the Width option under the "General" tab.

    153369448208-08-peocg.png

    For your 2nd issue, I recommend you to update the Ticket Purchase widget option and then click the "Update Widget" button. Here's a screen capture:

    1533694824updatetick.gif

    As you can see on the screen capture above, I click the backspace in the 2nd option and then press the space bar again.

    If you are still having issues, I suggest you try to re-embed the form using the iFrame method. Here's a guide: https://www.jotform.com/help/148-Getting-the-Form-iFrame-Code.

    Hope that helps. Thank you.

  • Profile Image
    lorbbyo
    Answered on August 08, 2018 at 01:27 PM

    Thank you for suggesting to increase the width of the widget. The field looks good now. But I am still receiving an error saying "This field is required" even when a selection is made. See screenshot.1533749216screenshot.png

  • Profile Image
    Jan
    Answered on August 08, 2018 at 01:54 PM

    I cloned your form and remove the payment field so that I can test it. I was able to replicate the issue you are referring to.

    However, after doing a minor change in the widget options and then updating it, the issue was resolved. Here's a screen capture:

    1533750141clonedform.gif

    May I ask if it is okay for me to sign into your account and update the widget myself?

    I will wait for your confirmation. Thank you.

  • Profile Image
    lorbbyo
    Answered on August 08, 2018 at 02:06 PM

    Yes that would be okay, thank you.

  • Profile Image
    Jan
    Answered on August 08, 2018 at 02:38 PM

    I have updated the widget. I also did a test submission in your form and I was able to submit it.  Here's a screen capture from your form:

    1533753524actualform.gif

    Please take note that I used a dummy credit card from Square to test it. I believe it is working now since I was able to submit the form.

    Kindly verify and let us know if the issue persists. Thank you.

  • Profile Image
    lorbbyo
    Answered on August 08, 2018 at 03:08 PM

    I have set the square payment to test mode. I am still getting the exact same error, "This is a required field" for the ticket widget. Any solution?

  • Profile Image
    Jan
    Answered on August 08, 2018 at 03:42 PM

    I did a test 2 submissions in your webpage and I was able to submit it. Here's a screen capture:

    1533756659testsubweb.gif.

    Just to verify, this is the form (https://www.jotform.ca/form/72255658132255) you are referring to right? Please do a test submission on the direct link of the form or in the webpage.

    Are you still having trouble? If yes, then please try using another browser just to check if it will work or not. If it does work on another browser, then please try to clear the cache of the non-working browser.

    I will also clear your form cache so that your forms will be refreshed from our servers.

    If the issue persists, then please try to remove the widget and then add it back.

    Hope that helps. Thank you.