Google reCaptcha goes blank on Safari.

  • Profile Image
    mryals
    Asked on August 16, 2019 at 01:14 PM

    Jotform,

    We recently started our service with you and thus far we have been impressed with all the options allowing us to really customize our forms. We have ran into an issue that has been reported by multiple users when they are submitting feedback to us.

    This only happens when using Safari as the web browser. The screenshot that I took is using Safari version Version 12.1.2 (14607.3.9).

    When you are getting to the bottom of the form and click on the Captcha section, you can only click one picture and then all of the images disappear and an empty white box is shown. Please see my screenshot attached. The green box around the issue is notated in my screenshot. 

    I have also included the link below where you can test the form in a Safari browser and see the issue for yourself.

    This is very concerning to us, as many of our users are Mac centric, and utilize Safari. 

    Your help in getting this resolved quickly would be greatly appreciated.

  • Profile Image
    Kevin_G
    Answered on August 16, 2019 at 03:36 PM

    We have been testing the embedded form on your page and we can replicate the issue you mentioned; however, the issue does not happen on the standalone version of the form, example: 

    1565983446safari captcha3.gif

    I can see your form has been embedded using the default JS code, please try embedding your form using the iFrame code, this guide will help you getting it: https://www.jotform.com/help/148-Getting-the-Form-iFrame-Code 

    Let us know how it goes. 

  • Profile Image
    mryals
    Answered on August 19, 2019 at 01:23 PM

    Kevin,

    Thanks for the quick reply. I followed the instructions that you provided for the iFrame code setup. The forms Captcha does work correctly in Safari Version 12.1.2 (14607.3.9).

    We have noticed that the Captcha experiences the same white blank box behavior in Safari Version 13 (beta for Safari in Mac OS Catalina), which will be releasing in the near future.

    Will you have this issue fixed once OS Catalina is ready for public consumption? This will be needed for our forms to keep running correctly when Catalina arrives.

    Also - If you can view our form at the link provided in my original message, you will see that the Iframe code actually cuts off the outline of the form at the very bottom under the 'SUBMIT' button. I am unable to adjust any code to make the lower outline of the form appear. We would appreciate if you can look into this.

    Please let me know on both requests above.

    Thank You,

    Mark

  • Profile Image
    Kevin_G
    Answered on August 19, 2019 at 01:55 PM

    Beta versions of browsers usually have compatibility issues, this should be fixed by the browser developers at the final version, if you still notice the issue on the final version with the embedded version or the direct form URL, please let us know so we can check if the issue can be resolved from our end. 

    Regarding your other request, this has been moved to another thread in order to assist you better, we will continue assisting you here: https://www.jotform.com/answers/1931943 

    Thanks.