monday.com integration hangs at saving

  • Profile Image
    Abdul Qader 
    Asked on September 18, 2019 at 04:49 AM

    Hi, I've set up the matching fields between monday.com and my Jotform, but there seems to be an issue in "Saving" the settings (the option is greyed out upon clicking and the integrations are lost once I exit the page shown in the screenshot).

    However, the integrations work perfectly when I used the "test integration" tool.

    Could you assist on why the settings can't be saved?

    Screenshot
  • Profile Image
    Abdul Qader 
    Answered on September 18, 2019 at 04:54 AM

     Proof of successful integration of the form as tested using "test integration" button below:

    1568796793Capture2.JPG

  • Profile Image
    Kiran
    Answered on September 18, 2019 at 08:04 AM

    Could you try testing the integration on a different browser and see if that helps? Also, please see if there are error being displayed in the browser console that might help in investigating the issue.

    https://www.jotform.com/help/453-How-to-get-a-console-report-from-most-common-browsers

    Thanks!

  • Profile Image
    Abdul Qader 
    Answered on September 18, 2019 at 09:13 PM

    Hi, the integration still does not work in different browser (switched from Chrome to IE). The console screenshot is given below. Please advice.


    1568855549Capture3.JPG

  • Profile Image
    Girish
    Answered on September 18, 2019 at 09:49 PM

    We apologize for this inconvenience caused. I created a demo form with Monday.com integration and was able to successfully complete the integration.

    15688572851909_4.png

    Additionally, I also cloned your form and then again the integration was saved successfully.

    Please check your internet connection, clear your browser cache and try again. Do also login using an incognito window of your browser and then try to integrate to see if the integration is getting saved successfully.

  • Profile Image
    Abdul Qader 
    Answered on September 18, 2019 at 10:02 PM

    This is really strange. I've tried everything you suggested, and I'm still stuck at the grey-ed out "SAVING" button once I try to Save.

    My internet is definitely fine, the fact that the Integration fails to complete despite "Test Integration" working flawlessly (I see the correct update in my monday.com account) is mindboggling.

    Help please!

  • Profile Image
    Girish
    Answered on September 18, 2019 at 10:22 PM

    We truly apologize for the trouble caused. Are you receiving this same error on the console while using Chrome as I can see that you've provided us the console log from Edge?

    I've also cleared your form cache if that helps.

  • Profile Image
    Abdul Qader 
    Answered on September 18, 2019 at 10:31 PM

    Here's the console report from Chrome

    1568860282Capture4.JPG

  • Profile Image
    Jed_C
    Answered on September 19, 2019 at 12:49 AM

    Your screenshot shows that you timed out because of the image on the upper right corner of your Jotform builder page (avatar).

    Kindly try logging in using incognito mode (if using Chrome) or private browsing (if using Firefox) then try integrating again with Monday.com

    Let us know how it goes.