Lightbox is no longer populating the form as of this week?

  • Profile Image
    STMJot
    Asked on March 02, 2020 at 06:02 PM

    We have Jotforms installed on PPC landing pages and they have worked for quite a few months exactly as expected.

    We noticed today that the forms were not filling in on the Lightbox?


    See here:  https://healthycleaningoffer.com/5StarsGuelph


    We also tried putting the code on just a standard WordPress test page and the same thing is happening... the lightbox opens as expected, but the form does not populate?

    Please help resolve this

    Thanks

    John

  • Profile Image
    jherwin
    Answered on March 02, 2020 at 11:23 PM

    Hello John - Can you please explain your question in details? How do you populate the form?

    Is it by URL parameters? Can you please try to re-embed the form and see if that will fix the issue?

    Looking forward to your response.

  • Profile Image
    STMJot
    Answered on March 03, 2020 at 08:30 AM

    So I installed the Embed Lightbox code for the form with an image button to replace the text.

    The form has worked every day on all of the landing pages for months.

    Now when you click on the Red Button that says "Schedule Your Cleaning Now" ...the lightbox pops up but the form does not show up in the lightbox... it is just blank.

    Here is the test page on a basic Wordpress setup that I have tried the code on yesterday as well and the I get the same result. 

    https://www.screamingtreewebinar.com/test/


    As you can see the lightbox opens when you click on the button but it is now blank and does not show the form.

    I tested this page and the other PPC landing pages on my mobile phone as well and the same thing occurs, lightbox opens but now there is no form?

    Since this was working fine on multiple landing pages for many months and then suddenly just stopped - there must be some issue on the Jotform side.

    Thanks

    John

  • Profile Image
    jherwin
    Answered on March 03, 2020 at 09:49 AM

    Lightbox embed code is working fine on my webpage: https://www.jherwin-jotform.tech/test07.php

    Your webpage has many console errors. Can you please tell us which form is embedded in the webpage you mentioned and we will try to embed the form in our test webpage to see if we can reproduce the issue or not?

    Guide: Where-to-Find-My-Form-URL

    Looking forward to your response.

  • Profile Image
    STMJot
    Answered on March 03, 2020 at 11:13 AM

    The form that is embedded is:  https://form.jotform.com/91893950058266

    See below image for where the lightbox is on our landing page: https://healthycleaningoffer.com/5StarsGuelph


    1583251721Clipboard01.jpg


    And as I noted, I have tried the code on a TEST page as well and the I get the same result, here: https://www.screamingtreewebinar.com/test/   

    Not sure what changed, but getting it working again on the landing pages is important


    Thanks

    John

  • Profile Image
    ashwin_d
    Answered on March 03, 2020 at 03:41 PM

    I did try to test your embedded form and it seems to display the lightbox form correctly. I was able to view and submit form successfully. After the form was submitted, it seems to show redirect blocked notification. Please check the screenshot below:

    1583268001lightboxFrm1.gif

    Is this the issue you are having or you are not able to view the lightbox form?

    We will wait for your response.

  • Profile Image
    STMJot
    Answered on March 03, 2020 at 04:21 PM

    I am not sure how you are able to have the form show up in the lightbox in your gif?

    I am not able to have the form show in the ligthbox anymore since Monday and I have tested on 3 computers (both Chrome and Firefox) and 2 separate mobile devices and have had 3 other people test remotely on their computers and mobile ...an stating it is a blank box like you can see in this image...

    1583270073Guelph Deal_ - healthycleaning


    So I am not sure why no one else can see the form?  

    Also, the form input redirect being blocked, is that an issues with heightened browser security in Chrome etc?  Is there anything we can put into the form code to prevent the end users browser from not redirecting them to the thank you page after submitting their form?

    Thanks

    John

  • Profile Image
    jherwin
    Answered on March 03, 2020 at 08:28 PM

    Hello John - Upon further checking, there is two lightbox form on the same page. In order for it to work properly, please use feedback.js for the second embed code to prevent conflict.
    1583284950feedback.png
    Please give it a try and let us know how it goes.

  • Profile Image
    sinan
    Answered on March 04, 2020 at 05:14 AM

    Hi,

    Sorry for the inconvenience.

    The issue is resolved.

    Please clear your browser cache and try again. Feel free to post to this thread if you encounter any problems.

  • Profile Image
    STMJot
    Answered on March 04, 2020 at 09:38 AM

    Thank you for fixing this


    John