Required payment didn't go through

  • Profile Image
    jenniferreedphotos
    Asked on June 20, 2020 at 06:12 PM

    I require a retainer payment when the contract is submitted (its marked as required with the little red asterisk) Client just submitted one and said she put in her payment info but when the contract came through its blank and I don't see the payment in my square account.

    Left is a ss of a contract with the payment that was submitted, right is the contract and no payment info showing like it wasn't even added. 

    Screenshot
  • Profile Image
    Jimmy_D
    Answered on June 20, 2020 at 07:30 PM

    This generally happens when the integration is on test mode.

    Which one of your forms are you having issues with? 

    We look forward to your answer.

  • Profile Image
    jenniferreedphotos
    Answered on June 20, 2020 at 07:39 PM

    It's my bump to birthday contract. 

  • Profile Image
    Mike_G
    Answered on June 20, 2020 at 08:22 PM

    Thank you for the additional information. I have checked your Jennifer Reed Photography Bump to Birthday Session Contract form and I can confirm that the Square payment field is properly set up and the field is also set as required. Meaning, there is no chance the form can be submitted without having that field filled or completed.

    Since I only see one submission in the form you mentioned, can you confirm if the submissions shown in your screenshot above are from the same form? I can only assume that the one on the left was submitted earlier than the one on the right. Was the payment field in your form original set as required or it was just set as required after the submission on the right?

    Also, is your form embedded on a website? Or, was the form submitted only from its direct link? Have you tried testing the issue on your end to see if you are able to reproduce the issue? I wasn't able to try if the form required error will be triggered when I submit your form with the payment field left empty since your form is password protected.

    We will wait for your response.

  • Profile Image
    jenniferreedphotos
    Answered on June 20, 2020 at 08:27 PM

    The one on the left is my family session contract and the right is the other mentioned above. The one on the left was submitted on 6/17. Both were submitted through direct links. Both forms were set to required payment when I created the forms before any submissions came in. I have temporarily taken the password off the forms if you want to try it out. 

  • Profile Image
    roneet
    Answered on June 20, 2020 at 09:08 PM

    I was testing your form but could not submit it without the payment fields filled up.

    15927013951.PNG

    May we know how were you sharing the form to the user? How are they filling up the form? Is the form embedded on your website or they using the direct link of your form to fill up?

    Could you please clarify these points so that we can investigate further.

    Thanks.

  • Profile Image
    jenniferreedphotos
    Answered on June 20, 2020 at 09:10 PM

    I mentioned above they were direct links I copied and sent to them. The one in question said she entered her cc info and submitted it. But when it came through as a submission there was no payment info attached and no payment showing in my square account.

  • Profile Image
    Vanessa_T
    Answered on June 20, 2020 at 09:43 PM

    Since your payment field is in Live Mode, we cannot test it on our end. Before we send this to our backend team, can you please try creating a test product with $1 amount, then make a test submission on your form.

    Kindly share a screencast while filling out the form so we can see what exactly happens on your end. Please also share a console log before and after submitting.

    How-to-get-a-console-report-from-most-common-browsers

  • Profile Image
    jenniferreedphotos
    Answered on June 20, 2020 at 10:03 PM

    on my end everything looks normal. i filled out all the fields and did the test $1 payment and it shows on the submissions. i have no idea how my client submitted her contract and no payment information was saved or processed. 


  • Profile Image
    gerardw
    Answered on June 20, 2020 at 10:20 PM

    Thanks for the confirmation.

    Could you check with the user if she was able to get the Thank you page after submission and if she was charged the amount on her credit card?

    I have additionally cleared form caches on your account. If she wasn't charged, could you ask her to submit the form once more.

    There is also an incomplete submission upon checking your Form submission page.


  • Profile Image
    jenniferreedphotos
    Answered on June 20, 2020 at 10:29 PM

    She said she saw the thank you page. She is going to check her card tomorrow to see if anything shows. I did see the incomplete submission im not sure what that is from but looks like it was started around 8:57pm.

  • Profile Image
    roneet
    Answered on June 20, 2020 at 10:48 PM

    1. I'll suggest you add the Get User's Agent in your form so that going forward we could get the browser information in case you encounter the issue again.

    https://www.jotform.com/widgets/get-user-agent

    2. Please confirm if the user was charged while she filled the application?

    3. Could you please confirm if she has Javascript enabled in her browser or any pop-up/adblocker installed in her browser which has disabled the validations in the form.

    4. Which browser she were using?

    I am sorry I was testing your form which you are seeing in your Incomplete submission. I was trying to test all the possibilities that could have bypassed the validations but could not replicate. You may discard the Incomplete submission.

    Looking forward to your response.

    Thanks.

  • Profile Image
    jenniferreedphotos
    Answered on June 20, 2020 at 10:54 PM

    Ok I will delete that submission. I will update once I find out if she was charged or not.


    I'm unsure of her browser info I believe she used her phone but I will ask tomorrow. 


    I have added the get user agent widget to my forms thank you!

  • Profile Image
    roneet
    Answered on June 20, 2020 at 11:05 PM

    If she has used the phone to fill, please ask here which phone she is having and which browser she has used to fill?

    We will run a few tests when she confirms the details so that we could share all our findings with our development team when we are escalating the ticket.

    We look forward to your response.

    Thanks.