Jot-form Questionnaire not Populating in Word template in Integromat

  • Profile Image
    mgogna
    Asked on June 23, 2020 at 04:22 PM

    I've created a Jotform Questionaire and a scenario in Integromat titled ‘FSP Questionnaire’, in an attempt to populate a ‘Word Template’ from answers received on the Jotform Questionnaire. The Word Template is stored on Drop Box and t

     In Summary: (Screenshot #1)

    1)    Step 1:  Jotform – We wait for submissions (we have tagged questions).

     1)    Step 2: DropBox: We access a stored Word Template File saved in Dropbox.

    3)     Step 3:  MS Word Template -  the Word Template file has Merge Tags that copy over the data from Jotform

    3)     Step 4: DropBox: the updated Word Template file populated with data from Jotform Merge tags is saved to new Word file on  Dropbox



    I’ve used the help guide on Jotfrom à https://www.jotform.com/help/519-Populate-a-Word-Template-with-Form-Data

    I think the issue is I am unable to find ‘Simple value’ in the Value type pulldown menu in Integromat 'Microsoft Word Template'. *Please see uploaded Word File it has screenshots. (refer to Screenshot #2 - pic of Jotform Guide) 

    (refer to Screenshot #3 - picture of Integromat - Missing 'Simple Value Option) 

    When I run this the scenario in Integromat I get the following error messages(refer to Screenshot #4 - picture of Integromat error)

    4:40 PM The request was accepted. Waiting for the server. 4:40 PM Cannot initialize the scenario because of the reason 'Flow is empty and contains no configured module' 4:40 PM Scenario initialization failed with an error.

    Please let me know if you have any suggestions, I am not married to the process if there is a better way to get this to work. Any help is greatly appreciated. 

    Thanks, 

    Mohit 

    PLC Fire Safety Solutions - Marketing Manager. (www.plcfire.com)

    647-339-5979, email mgogna@plcfire.com 


  • Profile Image
    Basil_A
    Answered on June 23, 2020 at 05:57 PM

    Hi,

    I have managed to integrate the flow on one of my forms and it worked without any problems. I used the "value" field, the simple value field was not available for me either. That is definitely not the issue.  

    Are you trying to integrate all the fields in your form? 

    May I suggest trying the name field alone to see if you are able to use the flow with just one field only. It could be that some of the fields are not being recognized.

     

    If the file does not have to be a word file, I would suggest creating a PDF file in our PDF editor and having them sent to your Email once a submission is made.

    Please take a look at this guide for more information:

    https://www.jotform.com/help/503-How-To-Include-Submissions-As-PDF-Attachment-In-The-Email-Notifications

    You can also open the PDF editor to edit the format of the PDF file that is sent.

    Please let us know if you require any further assistance.