Form could still be submitted despite having required field

  • Profile Image
    YLhello
    Asked on December 21, 2020 at 01:18 PM

    Hi there,

    It seems that my form can still be submitted despite having required fields: https://form.jotformeu.com/202865015364352

    Would you be able to look into this and let me know how to fix this?

    Thanks,

    Vanessa

  • Profile Image
    Jessica_H
    Answered on December 21, 2020 at 03:01 PM

    Hi Vanessa, thank you for confirming with us.

    Please allow me some times to do some tests. I will notify you through this ticket soon.

  • Profile Image
    Jessica_H
    Answered on December 21, 2020 at 04:00 PM

    Hi Vanessa, thank you for the wait.

    Upon investigation, this might be due because you placed your submit button on the first page. Please kindly try to move your submit button on the second/last page. The errors should return when the user doesn't enter anything in the required fields. 

    1608584404_5fe10cd4e9142_

  • Profile Image
    YLhello
    Answered on December 21, 2020 at 04:22 PM
    Hi Jessica,
    Thanks for your help.
    When I move the submit button to the next page, the form is unable to be
    submitted: https://form.jotform.com/202865015364352
    Thanks,
    Vanessa

    ...
  • Profile Image
    Welvin
    Answered on December 21, 2020 at 06:10 PM

    I'll be checking this and get back to you. I think it's the styling of the form that's causing the problem.

  • Profile Image
    Welvin
    Answered on December 21, 2020 at 06:51 PM

    I'm sorry, but I see the page break was updated to work with some scripts, so hiding it with custom CSS works, but cannot be submitted until the page break buttons are clicked.

    I see two options here as your workaround:

    1. To remove the page break and have both form and image sections in two columns, like this https://form.jotform.com/203557300111944.

    2. To add "?jumpToPage=2" at the form URL so it will move to Page 2 automatically. So, the form URL would be published as https://www.jotform.com/203556444782966?jumpToPage=2.

  • Profile Image
    YLhello
    Answered on December 22, 2020 at 03:11 PM
    Hi there,
    Thanks so much for your help!
    I'm assuming the second option (adding ?jumpToPage=2) would work by adding
    the same to the src URL?
    Thanks again,
    Vanessa

    ...
  • Profile Image
    YLhello
    Answered on December 22, 2020 at 03:44 PM
    Hi there,
    Would it be possible to allow me to clone that form? I've made some changes
    and it appears to look different so I was wondering if I can clone the
    version that you copied? i.e. the one from this link:
    https://www.jotform.com/203556444782966
    Thank you!
    Vanessa

    ...
  • Profile Image
    YLhello
    Answered on December 22, 2020 at 03:44 PM
    Hi Welvin,
    Sorry for the multiple messages — when I try to do that for my version, the
    first page info seems to disappear:
    https://form.jotformeu.com/202865015364352?jumpToPage=2
    Thanks,
    Vanessa

    ...
  • Profile Image
    Welvin
    Answered on December 22, 2020 at 04:56 PM

    Hello Vanessa,

    I think it's the custom CSS codes. I can point out which one I did here, but I have copied the codes from my form to yours. It works now.

    https://form.jotformeu.com/202865015364352?jumpToPage=2

    Thanks

  • Profile Image
    Welvin
    Answered on December 22, 2020 at 04:57 PM

    I'm sorry, I forgot to answer your previous question. Yes, the SCR value will work with the parameter. I would suggest using the iframe embed when embedding the form.

    https://www.jotform.com/help/148-Getting-the-Form-iFrame-Code

  • Profile Image
    Bent_Ash
    Answered on December 22, 2020 at 05:42 PM


  • Profile Image
    Lorenz_A
    Answered on December 22, 2020 at 08:36 PM

    Hi there,

    We've received a blank message from you, kindly reply here https://www.jotform.com/answers/2779418 if you have any related questions with regards to your concern.

    Looking forward to your response.