Jotform Tables: Downloaded PDF attachments can't be opened

  • Profile Image
    VDRESG
    Asked on March 11, 2021 at 04:47 PM

    That leaves me with the other issue that arises when I try to download all attachments from the "Tables" section. This usually generates a .zip file, sends me an email with the link to the generated zipped file, and then I can download the file, unzip it in a local folder, then read the attachments (generally in pdf form).

    What currently happens is that I click on the "Download all documents", the pop up telling me that the system will send me a link appears, I click "I understand", then I receive a link to the file. Up until then, it all goes according to plan. What's wrong is that the zipped file can be unzipped just fine, but some/most files inside the archive appear to be truncated. Directory structure is OK, but the pdf files are incomplete, and the sizes are rather small (goes as low as 7kb). Looking at the file using an HEX editor shows no %%EOF at all at the end of the pdf file.

    I have tried downloading the zipped file using more than one system, and more than one operating system/browser combination and the same thing happens (my main system runs osX Catalina, also tried from Windows 10 using Chrome as well as edge, and Ubuntu using Chrome and Firefox). I tried opening the .zip file using the regular osX inflator, and on Windows tried both 7zip, Winzip and the vanilla windows broker. On linux/Ubuntu, I only tried Ark. With all these programs, I achieved the same result, which tells me that there might be something astray with Jotform's attachment handling during compression.

    I'm open to any suggestions. I would really like the "download all attachment" feature to be back up and running for my purposes as this saves me tons of time.

    Best regards,

  • Profile Image
    Cecile_A
    Answered on March 11, 2021 at 04:58 PM

    Hello,

    I checked my own tables but I cannot seem to find the Download all documents option.

    1615499843_604a92433b758_18.png

    Could you please tell us what form is having this issue?

    Looking forward to your reply.


  • Profile Image
    VDRESG
    Answered on March 11, 2021 at 05:05 PM

    Thank you very much for your help! Sorry for the mistake : it is not Download all documents but Download attachments. I mainly have problem with this form

    https://www.jotform.com/inbox/203235856857263 (almost one PDF in every form can't be opened).

  • Profile Image
    Cecile_A
    Answered on March 11, 2021 at 06:45 PM

    Could you please try to download the attachments of one particular submission only and see if there's any difference?

    Also, if there errors displayed when you try to open the PDF attachments you have downloaded, kindly send us a screenshot of it.

    Guide: https://www.jotform.com/help/438-how-to-post-screenshots-to-our-support-forum

    We await your response.

  • Profile Image
    VDRESG
    Answered on March 14, 2021 at 08:42 AM

    Hi, It's working when I download the attachments one by one since I clear the cache also if in the pages "Tables" I check one of them and ask to download attachments. When I ask to download attachments for all forms, then receive the email, dowload the files and unzip them, for few of them this screen appear (the file is damaged and cannot be opened):

    1615724600_604e003831d42_Capture d’é

    For example, for this form (https://www.jotform.com/inbox/203235856857263/4871479417114795825), all of the attachments can't be opened. All of them have a size of 16ko

    1615724917_604e0175a5c80_Capture d’é

    If I download them one by one, it's working as you can see by the size of the files1615725118_604e023ead628_Capture d’é

    I try again this morning to download all the attachments and it seems that it is working now. Did you work on the bug?

    Thanks you very much for your help!

  • Profile Image
    Richie_P
    Answered on March 14, 2021 at 11:07 AM

    Thank you for explaining the issue with your form.

    Our developers are constantly working on errors/issue in the form and the issue seems to have been fixed.

    However, if the issue persists, let us know so that we can check it further.