What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Unwanted Prepopulated String

    Asked by cfresolone on May 20, 2014 at 05:17 PM

    Hello! My form seems to work well, but a string of information (the URL of the page upon which the form resides), is population one of my fields, and I can't pinpoint where it is happening. I checked the default value of the field and it is indeed empty (as far as I could tell). Can you help please?

     

    https://sites.google.com/a/tucsongirlschorus.org/home/Home/about-us/choirs-and-programs/tgc-choir-camp

    Page URL:
    https://sites.google.com/a/tucsongirlschorus.org/home/Home/about-us/ch<br/>oirs-and-programs/tgc-choir-camp

    Screenshot
    pre-populated checked hello and
  • Profile Image
    JotForm Support

    Answered by jonathan on May 20, 2014 at 07:40 PM

    Hi,

    This is not happening when using the form's direct URL http://www.jotform.us/form/41008388537155 

     

    It is possible that some script on the website where the form is currently embedded is causing this glitch.

    Can you please try re-embedding the form to your website using instead its iframe code embed.

    Guide: -Getting-the-Form-iFrame-Code

    Please inform us if issue persist.

    Thanks!

     

  • Profile Image

    Answered by cfresolone on May 21, 2014 at 09:51 PM

    Thank you for your reply. Since I am using Google Sites, I'm uncertain as to how to use the iframe code--I believe I have read that iframes don't work in Google Sites, but I can't be sure. I pasted this code into the html, and nothing appears--the page is blank. I try going through the insert--iframe gadget, same result. What information do I not have, or what am I missing?

  • Profile Image

    Answered by Cesar on May 22, 2014 at 12:28 AM

    Google Sites requires for your webpage's elements to be secured. In which case you must obtain the secure SSL version of your URL.

    https://shots.jotform.com/cesar/screens/secureformandiframe.png

    Do let us know if the issue persists after working with the secure URL. Thank you.

     

     

  • Profile Image

    Answered by cfresolone on May 22, 2014 at 10:07 AM

    Thank you, this was what I was missing! Much appreciated!

     

    Chris