What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    I have a problem with required fields

    Asked by umhlanga on August 07, 2014 at 08:04 AM

    I have this form: http://www.jotform.com//?formID=41883705446562  published in the right column on my website. 

    We have had 18 submissions and most of them are appearing in our email with no NAME.

    I have logged in to view the submissions in the Jotform backend and the names seem to be showing perfectly.

    Do you have any idea why we would be experiencing this problem?

    Page URL:
    http://www.bankonassets.co.za/

    Screenshot
    problem Submissions JotForm name
  • Profile Image
    JotForm Support

    Answered by KadeJM on August 07, 2014 at 10:45 AM

    So your " name field " answer is basically blank. I inspected your email notifications and also your form itself so both of these look okay so far. I am going to do a few more tests to check this further and I will be right with you in a moment after I inspect this problem more.

  • Profile Image
    JotForm Support

    Answered by KadeJM on August 07, 2014 at 11:08 AM

    I tested this a couple of times but I am unable to replicate the issue. It seems to be working fine on my end and I see your current setup is fine and dandy as well. I've cleared your form cache's of this on our end to refresh your forms. Can you please try this again and let us know?

    After looking deeper into the issue I found your submissions have a " . " (period) in place of the name. I am thinking that perhaps the period might have accidentally been entered into the name field or overwritten it unintentionally. If you take a closer look at your submissions with the name field you'll see what I mean. I think the notification just didn't pick it up and read it as a symbol or it may have been a minor problem that was only temporary.