What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Had issues with the radio button option

    Asked by ahundov on September 25, 2014 at 01:05 PM

    The first field on my only form here used to be a radio button with several options (company, individual, other). The field was set to "required".

    I never had problems with this field until recently. If there were any errors on the page, I would normally see the alerts (red) next to the fields that contained errors, or were not completed while being required, etc.

    Recently, something changed. I noticed that whenever anyone tried to fill out the form (and all required fields were completed), after the "Submit" button was pressed, the users saw a a big black rectangle on the page with an error dialog. The error message stated that the "Profile Type" (that was the label of the radio button field) was required.

    The problem was that I was 100% sure the field was completed. I tested it a number of times and replicated the issue: even though I would select any of the radio button options, I would get the same error message. The only EXCEPTION was that if I would select an "Other" option and add a description next to it, then the error would not popup and the submission would be completed successfully.

    I have deleted and re-created that radio filed a number of times, and each time the issue would be there.

    In the end I decided to replace the radio button field with a drop down field. However, once the issue is resolved I would like to go back to the radio button option.

    Can you look into this issue? Thank you!

    Page URL:
    http://icarteam.us/service-application-form/

    radio button field problem label message
  • Profile Image
    JotForm Support

    Answered by Kiran on September 25, 2014 at 02:56 PM

    I understand that the Profile Type field was provided with radio button options and unable to submit the form unless Other option is selected.

    I've cloned your form to my account and changed the drop-down box to radio buttons to see if I can replicate the issue. But it is working as it should and was unable to reproduce the issue.

    Could you try replacing the drop-down box to radio buttons and see if the issue still persists? Please get back to us if you need further assistance in this regard. We will be happy to look into this issue further.

    Thank you!!

  • Profile Image

    Answered by ahundov on September 25, 2014 at 03:41 PM
    Kiran,
    Thank you for the quick reply!
    I replaced the drop down menu with the radio button, and the issue came
    back.
    As soon as I restored the radio button field, went to the web site and
    filled out a dummy submission. I selected the first option (Field
    Services - Established Company) and went through the rest of the form.
    Got the error after pressing the Submit button (see attached).
    I will appreciate if you help me solve this puzzle. Like I said before
    this radio button was working fine. I am not sure what changed.
    ...
  • Profile Image
    JotForm Support

    Answered by Kiran on September 25, 2014 at 04:07 PM

    Okay. I was able to send a test submission on the website using chrome but not on Firefox. However, using the direct JotForm URL I was able to send the submission on Firefox. Could you confirm if you are experiencing this issue on only Firefox or any other browsers? Please let us know if there are any recent changes on your WordPress website? 

    Also, please try re-embedding the form using iframe method and see if the issue is resolved.

    Please get back to us if the issue still persists. We will be happy to assist you.

  • Profile Image

    Answered by ahundov on September 25, 2014 at 04:11 PM
    Ironically, I was testing the form exclusively in Chrome. I am not sure
    what's going on but it looks like I will have to revert back to the drop
    down option - that one does not cause any troubles, but I lose the
    "Other" option with the drop down.
    ...
  • Profile Image

    Answered by ahundov on September 25, 2014 at 04:21 PM
    I just tried Firefox too, and on the first try it did generate the
    error. Big difference is that when I was getting the error in Chrome,
    clicking on "go back" link in the error dialog did not do anything at
    all, whereas in Firefox I was taken back to the form screen, then
    without changing anything simply clicked the Submit button again and the
    form was submitted successfully.
    As I mentioned earlier, in Chrome there is no ability right now to go
    back to correct or re-submit the form.
    ...
  • Profile Image

    Answered by ahundov on September 25, 2014 at 04:31 PM
    This email is about Internet Explorer which turns out the worst of the
    bunch:
    when submitting the form via IE got the same error. What was worse was
    that when clicking on the "go back" link all the fields were wiped out,
    the Core Expertise field was not visible except for the title (no
    buttons or entry fields within Core Expertise).
    Re-filled all fields except Core Expertise and tried to resubmit hoping
    the Core Expertise entries are somewhere in the memory, but this time
    simply got a error message on the same page below the submit buttons
    telling me there were errors in the form.
    So, none of the three major browsers were successful, Firefox actually
    being the better of them in my testing. But as we know these days most
    people use Chrome, so this is the primary browser where the
    functionality needs to be perfect.
    I will clone the form as is for your testing, and will replace the radio
    button options in the original form copy.
    As to your previous question whether there was anything new on the
    Wordpress side of things, the theme was last updated I think in August,
    and I believe back in early September I was testing the form and it was
    working at the time with the radio buttons.
    ...
  • Profile Image
    JotForm Support

    Answered by Kiran on September 25, 2014 at 06:27 PM

    Thank you for the detailed information provided. Generally, we also recommend our users to use Chrome or Firefox browsers.

    Yes, a cloned form should work for us to investigate on the issue. However, we would also request you to create a dummy page on the WordPress and embed the form on it using iframe method.

    Let us see what best we can do in resolving the issue.

    Thank you!!