What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    [SalesForce Integration] INVALID_LOGIN: Invalid username, password, security token

    Asked by mdkelly on October 20, 2014 at 02:07 PM

    I am unable to complete SalesForce Integration.

    I am attempting to implement the SalesForce Integration tool, and getting Invalid User, password, security token or user locked out.

    I would like to connect to our development sandbox, but have tried to connect to our production environment as well.

    I created a new user, password, and retrieved an updated token for both the new user and myself.  (I don't want to update my production token, as that is in use by other apps doing data imports.)

    Question 1:

    Can I not connect to our production sandbox using your SF integration tool?

    Question 2:

    Why am I not able to connect even with my (Known Working) production login  and security token?

     

    Mike

     

    sandbox salesforce integration
  • Profile Image
    JotForm Support

    Answered by Mike_T on October 20, 2014 at 03:42 PM

    Yes, you should be able to use both SalesForce Developers Account and Regular Account in our integration.

    I have just tried the integration with my test Developers account, and it worked well.

    It looks like that SalesForce does not accept your login credentials. Is there are any errors on your SalesForce Login History?

    Here is an example of successful access from our integration:

    You might also try clearing your browser and form caches to see if that makes any difference with the integration.

  • Profile Image

    Answered by mdkelly on October 20, 2014 at 04:31 PM

    I have successfully logged in to both our .develop (sandbox) and production environments. I'm using the same "account" to log into each different database instance. 

    While there are errors  in the log file, there are most recently successful logins.  I've reset password and requested, and used a new security token in attempting to log into the JotForm integration wizard.  I don't get to the last page "Add to Contacts or Leads".  (Currently the process is running circles while waiting ... )  It shouldn't take very long for the connection to return the SF columns.

    What I do get is the spinning circle telling me to wait.. and wait...

  • Profile Image
    JotForm Support

    Answered by Mike_T on October 20, 2014 at 05:59 PM

    I think that I misunderstood your original question about the sandbox access. It appears that SalesForce use different login instances for Developer Edition Accounts and Sandbox access:

    Developer and Regular accounts:

    https://login.salesforce.com/

    Sandbox access:

    https://test.salesforce.com

    It means that Sandbox access might not work with our integration. Unfortunately, I can not test this since I have a Developer Edition Account only.

    Can you try the integration with your production login credentials through some other browser? As an alternative, you might try the SalesForce Developer Edition Account.

  • Profile Image

    Answered by mdkelly on October 21, 2014 at 10:41 AM
    I can log in to the Production instance of SalesForce…
    Will need to open a new ticket as not all SalesForce fields are showing up in the dropdowns.
    Michael D. Kelly
    Interim Director for Applications and Automations
    Richard Bland College of William & Mary
    8311 Halifax Road
    Petersburg, VA 23805
    PH: 804.862.6419
    [cid:image001.png@01CE87A5.3298C770]
    "Who is a wise man and endued with knowledge among you? let him shew out of a good conversation his works with meekness of wisdom." James 3:13
    ...
  • Profile Image

    Answered by Shadae on October 21, 2014 at 11:22 AM

    Hi mdkelly,

    I am happy to hear that you are now able to log into your SalesForce account through our integration.

    You can open the new thread regarding your missing fields and we will address that there.

    Please feel free to contact us if you need further assistance.

    Thank you for using JotForm!