What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Form not redirected to PayPal payment page.

    Asked by fchanmigration on April 10, 2015 at 08:47 AM

    Sorry to revive an old thread but I've been testing this again to get it ready for real use and after implementing everything I'm still not being directed to the payment page. 

    I have the conditional logic set up to redirect to the individual payment forms (paypal, bank deposit and stripe). 

    I then have the main form's submit button (called Next >) which redirects to a custom thank you page. 

    This is the set up that you have proposed and I have followed to a T. 

    However when I select a payment method and then I press the Next button I get redirected to the custom thank you page. 

    Any ideas?

    Thanks

    PayPal make a purchase redirect
  • Profile Image
    JotForm Support

    Answered by ashwin_d on April 10, 2015 at 08:55 AM

    Hello fchanmigration,

    I did check the conditions you have added in your form and found that in all the conditions you are redirecting users to "http://www.jotform.com/thankyou.html" page. This will always display the thank you message. Please check the screenshot below:

     

    You should actually add your form URL in the conditions on which you want to redirect. Please check the screenshot below on how to find your form's direct URL and add it in your condition:

     

    Hope this helps.

    Do get back to us if you have any questions.

    Thank you!

  • Profile Image

    Answered by fchanmigration on April 10, 2015 at 09:12 AM

    Thanks for responding but that's not actually my form. That was from the person who helped me last time. 

    The form is in the original post: http://www.jotformeu.com/form/50204841841347

    That's where I have set up all the correct redirects. 

     

  • Profile Image

    Answered by Ben on April 10, 2015 at 12:11 PM

    I believe that this is related to how your conditions are set.

    It seems that you made some changes to the labels and that the conditions were not updated - while our system will try to match them and update as you make a change, it seems that they were not updated correctly at this time.

    These are the original conditions:

    This is how it should be:

    Do make the change to them and let us know if by some chance the issue is still present for you.

  • Profile Image

    Answered by fchanmigration on April 13, 2015 at 04:19 AM

    Thanks Ben, that did the trick. 

    I wasn't aware that change in the labels didn't update automatically.

    Thanks for the help, everything works as planned.