What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Configurable List Widget not working in Safari

    Asked by veshman on December 31, 2015 at 09:13 PM

    Hi,

    It seems like people have had intermittent problems with this in the past, but I'm not sure what the resolution is.

     

    I have a form using Configurable List Widget that used to work perfectly in Safari, but now it's just blank space.

    It still works in FireFox.

    I've tried deleting all the cookies in Safari, but the problem is still going on.

     

    This is the form in question:

     

    https://form.jotform.com/52859300922961

     

    The Medication History is the first place the widget is used.

     

    I included screenshots from Safari and Firefox.

    Page URL:
    https://form.jotform.com/52859300922961

    Screenshot
    configurable list list widget configurable
  • Profile Image

    Answered by veshman on December 31, 2015 at 09:15 PM

    Here is the Firefox image

     

  • Profile Image
    JotForm Support

    Answered by Boris on January 01, 2016 at 10:16 AM

    Sorry to hear about the troubles you are having. I've tested your form in Safari 9 (latest) on OS X El Capitan, and the Configurable List widget appears and functions fine on my end:

    After checking your provided screenshot, it looks like you have uBlock extension installed in your browser. Can you please check if the form is loading fine on your end when your browser extensions are turned off?

    https://support.apple.com/en-us/HT203353

    If you do still experience the issue even without using any extensions, please let us know which version of Safari you are using and on which version of Mac OS X, and we will be happy to check further into what may be causing the issue for you.

    As far as I could check in my tests, the Configurable List widget seems to run fine on Safari. Please let us know how it goes.

  • Profile Image

    Answered by fraanco3 on January 01, 2016 at 07:58 PM

    I had the same problem in Safari with the Checklist Widget -- it would disappear and not display. Turning off a Safari plug-in (AdBlock) fixed this problem.

  • Profile Image
    JotForm Support

    Answered by Welvin on January 01, 2016 at 11:36 PM

    That's great to know. Please contact us again if there are any problems.

  • Profile Image

    Answered by veshman on January 04, 2016 at 12:00 AM

    Hello Boris (and fraanco3!), that was indeed the problem! thanks! I was using "uBlock" and had just installed it a couple of months ago. When I turned it off, the Configurable List started working again.

     

    Thanks!

     

    Bhavesh

  • Profile Image
    JotForm Support

    Answered by Boris on January 04, 2016 at 02:35 AM

    Thank you for updating us, Bhavesh, I'm happy to hear that disabling the ad-blocking extension managed to resolve the issue you were experiencing.

    Unfortunately, this is not something we can fix from our end. If you know which uBlock or AdBlock filter subscription was causing the issue and blocking the widget from loading, you can also report that to the maintainer of the list you were using, to see if they will add compatibility for your users who are also having uBlock or AbBlock installed.

    I hope this helps. If you need assistance with anything else, please don't hesitate to open a new support thread about it, and we will be happy to assist. :)

  • Profile Image

    Answered by veshman on March 02, 2016 at 08:49 AM

    Hi, unfortunately, this problem has re-surfaced.... The problem is occurring with all 3 of my browsers:

    Safari

    Firefox

    Chrome

    The Ad-blocker on Safari is disabled. The other browsers don't have blockers. I also disabled network monitoring filters but still no success

     

    Please note that this is occurring when I use the Wordpress embedding code

    -- [embed]https://form.jotform.com/form/52859300922961[/embed] --

    for this WP page:

    https://optimalchicago.com/ohc-health-intake-test/

     

    It *does* work with View Form URL https://www.jotform.com/veshman/OHC-intake

     

    Thanks for the help!

     

    Bhavesh

  • Profile Image
    JotForm Support

    (Private)

    Answered by Welvin on March 02, 2016 at 10:44 AM

    I have to move this as a new thread. Please check it here: http://www.jotform.com/answers/785680