Jotform not displaying on IE and Firefox

  • Profile Image
    Kayla_Hughes
    Asked on April 23, 2016 at 04:22 PM

    My form, "RSVP Wine Night" is embedded on my Unbounce landing page and displays fine on Chrome, but simply does not appear when viewed on Firefox 45.0.2 or Internet Explorer 11.212. I have found out that the iFrame does the same thing. If I use the source code, however, it will display on every browser, but it does not look aesthetically pleasing. Any ideas why this might be happening?

  • Profile Image
    Carina
    Answered on April 23, 2016 at 05:25 PM

    I checked and could see the form:

    Usually the iFrame method does not present any problem, but we need to inspect further this situation.

    Do you have a test page where the form is embed as an iFrame?

    We would need to inspect the code and run further tests in order to determine the causes of this situation. 
    We'll wait for more details in order to proceed. 

  • Profile Image
    Kayla_Hughes
    Answered on April 23, 2016 at 05:44 PM
    Hi there,
    Thanks for getting back to me. Yes, the form in your screenshot is how the Source Code displays. The iFrame and embed code do not display at all. I have changed the page back to using an embed code, so you can test that and see if it shows up in all browsers for you. (For me, it only shows up in Chrome).
    Thank you,
    Kayla
    Kayla Hughes
    (775) 297-4977
    5440 Louie Lane, Suite 106 Reno, NV 89511
    www.HughesCapital.com | www.HomeTodayTeam.org
    [Hughes Private Capital] [HomeToday_SideLogo_Email]
    ...
  • Profile Image
    Nik_C
    Answered on April 23, 2016 at 07:30 PM

    I opened your website in the Chrome and Safari and it works, however when i tried with Firefox it loaded the form and then the form disappeared. Could you please try embedding via iFrame method again and then let us know so we can see why this method does not  work for you.

  • Profile Image
    Kayla_Hughes
    Answered on April 23, 2016 at 07:44 PM
    Hi there. Yes, the exact same thing happens to me on both Firefox and IE: it shows up for a second and then disappears.
    I just changed to the iFrame method instead and republished the page. Check it out now. It has the same effect for me as the embed code does.
    Thanks,
    Kayla
    Kayla Hughes
    (775) 297-4977
    5440 Louie Lane, Suite 106 Reno, NV 89511
    www.HughesCapital.com | www.HomeTodayTeam.org
    [Hughes Private Capital] [HomeToday_SideLogo_Email]
    ...
  • Profile Image
    BDAVID
    Answered on April 23, 2016 at 09:41 PM

    Remove the code from your page, get the Iframe code again: http://www.jotform.com/help/148-Getting-the-Form-iFrame-Code

    Before you embed the code, paste it in a text editor like WordPad, you will notice two part of codes, only copy and embed the Iframe part in your webpage, example:

    The form should not present any problem now that the script part has been removed. Let us know if you need more help.

  • Profile Image
    Kayla_Hughes
    Answered on April 23, 2016 at 11:44 PM
    Thank you! That worked!
    -Kayla
    Kayla Hughes
    (775) 297-4977
    5440 Louie Lane, Suite 106 Reno, NV 89511
    www.HughesCapital.com | www.HomeTodayTeam.org
    [Hughes Private Capital] [HomeToday_SideLogo_Email]
    ...