Wordpress Embed: Widgets fail to load if form is embedded using [embed][/embed] code

  • Profile Image
    gaborka
    Asked on August 01, 2016 at 08:05 AM

    Embedded form: [embed]https://form.jotformeu.com/form/62060374131343[/embed]

    On page: http://cornholejatek.hu/vasarlas/

     

    If you choose "Festett tábla", then Radio Button Images are not shown at next form item.

    Everything seems right on preview side.

     

    What could be the problem?

     

    Thanks,

    Gabor

  • Profile Image
    Charlie
    Answered on August 01, 2016 at 09:58 AM

    Apologies for the inconvenience.

    Could you please try re-embedding your form using the iFrame embed code? Here's a guide on how to get that code: https://www.jotform.com/help/148-Getting-the-form-iFrame-code.

    It seems like the widget resources are being blocked if you use the [embed][/embed] on your Wordpress website. I'll investigate this further and we'll let your know.

  • Profile Image
    Charlie
    Answered on August 01, 2016 at 10:44 AM

    Apologies for the inconvenience. I was able to replicate the problem on my end. It seems like the embed code method [embed][/embed] fails to load the https://widget.jotform.io in the background. You can see on my screenshot below that there are errors shown in the browser console:

     

    I have forwarded this to our developers to have it checked and fixed. We will update you on this thread as soon as this is resolved. For the meantime, please do try the iFrame embed code as suggested. Apologies for the inconvenience.

  • Profile Image
    gaborka
    Answered on August 01, 2016 at 11:17 AM

    iFrame works, thanks for the quick support. :-)

  • Profile Image
    Charlie
    Answered on August 01, 2016 at 12:28 PM

    You are welcome. I'm glad it worked as a temporary solution. We will update you on this thread as soon as the fix has been implemented. 

    Thank you for your understanding.