Why does the email copy of my form show the wrong labels?

  • Profile Image
    HGC1903
    Asked on June 06, 2020 at 07:18 AM

    I have provided the link to the test response from my Jotform inbox and a jpg copy of the corresponding email.   As you can see the labels are different.   It is the email that is showing the incorrect values.



  • Profile Image
    shiro.ophal
    Answered on June 06, 2020 at 08:18 AM

    Hello!


    The email content for your form seems to be incorrectly setup. You'll need to edit it to fix the few mistakes.


    In the Form Builder, go to Settings, then click the edit button for the email address you're receiving notifications to. You will be taken to this page:

    If you scroll down, you'll notice that the errors you noticed in the email are shown. You can simply click on the text to edit it. Make sure you also edit the right-hand part to point to the correct form answers. You can find the correct code to add by clicking one of the lines, then going to Advanced:

    Scroll all the way down from there and expand the Field Details section:

    "Unique name" is the code you want to copy. You can modify them to make them easier to read, but make sure you double-check that they correspond to the right form answer.


    Here's a form I made with corrected fields and email: https://form.jotform.com/201573863728362


    You're likely seeing these fields due to your form creation process, duplicating a single field several times before editing its name, which led to the abnormal count and names.

  • Profile Image
    Welvin
    Answered on June 06, 2020 at 11:59 AM

    shiro.ophal's reply is correct. You can fix the labels in the template directly. You may also consider re-creating the template.

    Delete the current template: https://www.jotform.com/help/132-How-to-Delete-Notifications-Autoresponder.

    Create a new one: https://www.jotform.com/help/25-Setting-up-Email-Notifications.

    That would refresh the entire template with the most updated labels.