After completing my jotform I sent a test copy to my email address. Once I completed the form I pressed submit, the message said "please wait" and af

  • Profile Image
    WILLIAM_FOX
    Asked on January 11, 2022 at 07:36 PM
  • Profile Image
    Sam_G
    Answered on January 12, 2022 at 02:32 AM

    Hello William_fox,

    Are you referring to this form https://www.jotform.com/220095608607153?

    I have cloned and tested your form and was able to submit it.

    1641972735_61de83ffd0d32_

    Kindly check again and let us know if the issue persists.

  • Profile Image
    WILLIAM_FOX
    Answered on January 12, 2022 at 10:57 AM

    Thank you I will check now


  • Profile Image
    WILLIAM_FOX
    Answered on January 12, 2022 at 11:35 AM

    Hi Sam,

    Upon making some changes to the form, I tried to send out another test run. For some reason the form never went to my email so that I could retest and submit it. Is there any way to talk to you and have you walk me through this process? On yesterday, I was at least able to send the test form to myself and complete it. As you are aware, I was not able to submit it though. You said you tested the form and were able to submit it. For some reason, I don't see your form submission which I'm assuming should show up in our company email. And now today, as I tried to retest the form. I don't even see the form in my personal email, which is where I sent it too?

    Thank you for your quick response in this matter.

  • Profile Image
    VincentJay
    Answered on January 12, 2022 at 12:07 PM

    Hi,

    My colleague submitted a test submission to the cloned form.

    I tried submitting a test submission to your form and it is stuck on the "Please wait" button. Is it okay if you clone this form and try submitting again?

    Here's a screencast of my cloned form and I was able to submit it properly:

    1642007144_61df0a68d6e26_av31dfsf3.gif

    Here's the clone form link: https://www.jotform.com/220115134506946

    Here's a guide on how to clone the form: https://www.jotform.com/help/42-how-to-clone-an-existing-form-from-a-url/



  • Profile Image
    WILLIAM_FOX
    Answered on January 12, 2022 at 05:31 PM

    Hi Vincent and Sam,

    After making a clone of the document and completing it and submitting it. I am still getting the same results "Please wait" and after 20 minutes, I'm still waiting. Since this time I have tried to send the document to myself as if I were a client, only to have the document never reach my email address. Please help!

  • Profile Image
    VincentJay
    Answered on January 12, 2022 at 05:46 PM

    Hi,

    The form is set to private. Could you please set it to Public so we can open and test your cloned form?

    We'll wait for your response. Thank you!

  • Profile Image
    WILLIAM_FOX
    Answered on January 12, 2022 at 07:03 PM

    Yes, I set it to private because I assumed public was allowing everyone to see what I submitted, is that the case?


  • Profile Image
    WILLIAM_FOX
    Answered on January 12, 2022 at 07:12 PM

    Hi Vincent,

    I set it to public. After we get this issue straight, perhaps you can give me some assistance on what settings would best assist our needs.

    Thanks for you help!


  • Profile Image
    Cecile_A
    Answered on January 12, 2022 at 07:29 PM

    Hello,

    I have cleared your form caches. Could you please clear your browser's cache as well? Then, kindly try removing conditions with missing fields.

    1642033674_61df720a8b903_9.png

    If the issue persists, please change your cloned form's theme to any theme of your choice.

    1642033717_61df7235889af_10.png

    Let us know how it goes.

    Thank you.

  • Profile Image
    WILLIAM_FOX
    Answered on January 12, 2022 at 08:10 PM

    Hi Cecile,

    I removed all conditions with missing fields from the cloned Fox Tax Solution Client Tax Organizer as you requested. However, I'm not sure what the browser cache is? Please clarify

    Thanks.

  • Profile Image
    roneet
    Answered on January 12, 2022 at 09:31 PM

    I see you have certain show/hide conditions and you have marked those fields as a mandatory fields by default.

    Please make those fields non-mandatory by default and set conditions to those fields to require them only when those fields are shown.

    https://www.jotform.com/help/367-how-to-make-a-field-required-based-on-users-answer/

    To refresh the browser cache follow this:

    https://www.refreshyourcache.com/en/home/

    Thanks.

  • Profile Image
    WILLIAM_FOX
    Answered on January 12, 2022 at 10:12 PM

    Hi Roneet,

    I have cleaned the browser cache. You mentioned that I have certain show/hide conditions that I have marked as a mandatory fields by default?

    I'm not sure how to make those fields non-mandatory by default and how to set the conditions to those fields so that they are only required when those fields are shown. Please assist? I think its the default word that is throwing me off.

    Thank You



  • Profile Image
    Jessica_H
    Answered on January 12, 2022 at 11:58 PM

    Hello,

    To make your fields non-mandatory, you will need to select the fields that were marked as Required, then Unrequired them. You can press CTRL+A on your keyboard to select all the form fields, then click on UNREQUIRED option above.

    1642049806_61dfb10e8046c_

    After that, you can add Conditional Logic which will REQUIRED the user to fill certain fields upon a certain condition, such as below:

    1642049861_61dfb145d11c7_