What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Lead not sent to Salesforce

    Asked by zoeoakley on May 28, 2014 at 07:37 AM

    I am having another problem. When I tested my form it worked fine and my lead went into Salesforce. But not I've put it on a live page and it records the submission in jotform, but it's not appearing in Salesforce as a lead. Any ideas?

    salesforce leads mapping fields salesforce leads
  • Profile Image

    Answered by bob on May 28, 2014 at 08:23 AM

    Thank you for contacting with us.

    In this type of problem, we suggst you to reintegrate your form with JotForm again. Have you tried yet? This might help. Please be careful while mapping your form fields. If there's problem in mapping, the data won't export to Salesforce properly.

    You should also make sure to select "All Open Leads" from the dropdown menu. Follow the screenshot:

     

    Finally, if everything's doing fine everywhere except your live webpage; then please "Embed Your Form with Iframe Code" and use it in your webpage. Because there's a possibility of having JavaScript conflict between the source code of your form and your webpage.

    Please get back to us with updates about your query.

  • Profile Image

    Answered by zoeoakley on May 28, 2014 at 08:59 AM

    thank you.

    Ok what seems to be happening is this: I have 3 check buttons at the bottom of my form for DPA questions. If I fill in the form and don't check any of these, then it works and the lead goes into Salesforce. However, if I fill in the form and check any of the boxes then the lead does not go into Salesforce. The mapping is correct as far as I can tell.

    Any thoughts?

  • Profile Image
    JotForm Support

    Answered by Welvin on May 28, 2014 at 10:38 AM

    Am I right to assumed that the three checkbox fields are custom fields into your Salesforce account? Have you make sure that the field properties are the same with the form field? Well, the checkboxes are properly mapped so I think that was the case, but I need to confirm if you are using the Picklist (Multi-select) option:

     

    Also make sure to check your Unread Leads. 

     

     

    Thanks

  • Profile Image

    Answered by zoeoakley on May 29, 2014 at 11:06 AM

    I tested it using the Picklist (multi-select) option but this doesn't give me the answers I require. I need these 3 fields to be Checkboxes, but it doesn't record them in Salesforce if I use Checkbox.

    Please advise?

  • Profile Image
    JotForm Support

    Answered by KadeJM on May 29, 2014 at 03:00 PM

    Looking at this problem more I believe that this is probably an issue due to the fact that only certain fields are accepted with this integration. I am trying to test this further between the multi-select and also the checkbox but so far no luck. It was being ignored on my end so far. If you don't mind I would like to request a little bit more time so that we can research this problem further. I started checking this on a test, but I realized it would be better to check this more accurately with a form similar to yours. 

    I see you mentioned you have a form with dpa quesitons, but so far I am not finding that unless I've misunderstood it possibly. Can you please clarify and confirm with us which form this is for? And I do apologize for any of my confusion about this in advance.

  • Profile Image

    Answered by zoeoakley on May 30, 2014 at 04:59 AM

    Yes if you could do some testing and see if there is a solution, that would be appreciated. I have created 4 new forms in the last 3 days which are all the same (MWL form, Creative Week form, Cannes Lions form, ALF Football Fever) and you will see the 3 DPA questions at the bottom of each as checkboxes.

    Let me know if you have any luck.

    thanks

    Zoe

  • Profile Image
    JotForm Support

    Answered by Welvin on May 30, 2014 at 07:56 AM

    Hi Zoe,

    I really can't replicate the issue here. How about creating a new leads? This time, make sure that those checkboxes has the same selection when it comes to SalesForce. This is what I have made when adding the custom fields:

    1. I picked the Picklist (Multi-Select)

    2. In the field details, I have only the following:

    a. field label

    b. "Single Dot" in the pick list values

     

    ...I am specifically looking to this section. Is this what you've done when creating the custom field?

     

    If you look at the below screenshot, all data have been forwarded to Salesforce:

     

    Maybe, the mapped checkboxes have a different properties? I have mine as a normal custom field with no validation rules, triggers  inside the salesforce fields section.

    Why is it that your checkboxes in salesforce has: Opt-in Email and Opt-Out Email, is that the actual field name or a special function?

    Thanks

  • Profile Image

    Answered by zoeoakley on May 30, 2014 at 09:50 AM

    Opt-in and Opt-out are just the field names.

    That's what I did when I tried it as a picklist, but that's not the correct field type. I want a checkbox that only has a tick or no-tick option. But if i use the checkbox field then try to submit the form as a lead, the lead does not go into Salesforce.

  • Profile Image

    Answered by jedcadorna on May 30, 2014 at 12:17 PM

    Hello,

    Very strange behavior, I tested a cloned version of this form http://www.jotformeu.com/form/41473253023344 sometimes it does work even with all of the checkboxes are selected.

    I tried redoing some of the fields and now the form no longer works so I tried creating a custom field to map Company, Job Title, How did you here about us?, and Organisation type then re-integrated the form and now the form no longer even the check boxes have been checked or not.

    Why those fields? My first test was leaving the Job Title blank and it does not send data to Leads. I tried removing the Job Title then the integration stops working. Reintegrated back then and left How did you here about us? and Organisation type empty then integration no longer sends data again so what I did was tried to make some custom fields for these fields then it no longer breaks the integration not sure what data type you have. Can you try making a custom fields for these then make some test and see if this helps.