Unable to submit a form. Stuck on "Please wait.."

  • Profile Image
    smwise2
    Asked on July 14, 2014 at 10:03 AM

    I have a form, "Agency Information".  Instead of the submit button saying "Submit" it says "Please Wait" and won't let it submit.  Why would this be doing this, and how do I fix it?

    Shawn

  • Profile Image
    jedcadorna
    Answered on July 14, 2014 at 11:30 AM

    We are sorry for the inconvenience.

    I just tested your "Agency Information" form and was able to submit without any issues. Try to clear your browsers cache or use a different browser to see if you will still encounter the same behaviour.

    Here's an image of the successful submission.

  • Profile Image
    smwise2
    Answered on July 14, 2014 at 12:26 PM

    I am still having the same problem when I put it on my server.

    http://www.empireunderwriters.com/appointed-now/Main_Form_Verdana.html

  • Profile Image
    ashwin_d
    Answered on July 14, 2014 at 01:22 PM

    Hello smwise2,

    I did check your web page where you have embedded your form and I am able to replicate the issue you are having. When we reach last page of your form, the submit button text was already "Please Wait". I also check your form with its direct URL and it seems to be working as expected. 

    As you have embedded your form with its source code, there seems to be some code conflict between your form's script and other script available in your web page. Please embed your form with its iFrame embed code and that should solve your problem. The following guide should help you in grabbing your form's iFrame embed code:  http://www.jotform.com/help/148-Getting-the-Form-iFrame-Code

    Hope this helps.

    Do get back to us if you have any questions.

    Thank you!

  • Profile Image
    carestaffingprofessionals
    Answered on July 11, 2016 at 08:58 PM

    My form says the same thing. I can not figure out how to fix this issues.
  • Profile Image
    ashwin_d
    Answered on July 11, 2016 at 10:45 PM

    Hello carestaffingprofessionals,

    I have moved your question to a new thread and you will be answered here:  https://www.jotform.com/answers/880254 

    Thank you!

  • Profile Image
    maestrobilly
    Answered on June 02, 2017 at 07:16 PM

    Hi there!

    Same problem here. People are telling me that it keeps on "Please Wait" forever.

    My form is this one

    https://form.jotformeu.com/71514412384350

    And this one

    https://form.jotformeu.com/71304615330343

     

    Thanks

     

     

     

  • Profile Image
    Aury
    Answered on June 03, 2017 at 12:17 AM

    Dear maestrobilly

    I tested your above indicated form, but I was not able to reproduce the issue, as shown in the following animation:

    Please try clearing the browser cache and let us know if the issue persists.

    Regards.

     

  • Profile Image
    maestrobilly
    Answered on June 03, 2017 at 04:57 AM

    Aury,

    Thanks for the fast support.

    I managed to embed it in a different way and the problem was solved.

    :)