Form is not going back to top when submitted

  • Profile Image
    meyermichele
    Asked on August 07, 2016 at 11:01 AM

    I changed the script as you suggested and now the form is showing which I am very happy about so thank you again.  However, now when the form is submitted it is just showing a blank white form unless you scroll up to see the confirmation message.  It never use to be that way before.  The confirmation message would appear without having to scroll.  My concern is that I know the less computer savvy people will not think to scroll up and due to the nature of my business it is important that they see the message.  I will attach a screen shot of that too.  Can this be fixed?  Thank you

  • Profile Image
    Welvin
    Answered on August 07, 2016 at 11:17 AM

    I have tested your form and can confirm that the issue is there, the form is not going back to the top when submitted. The default embed method should do it, but I think the changes in the form address is affecting this function. 

    How about embedding your form using our iframe method? Can you give it a try? 

    https://www.jotform.com/help/148-Getting-the-Form-iFrame-Code 

    Note that the iframe gives you the HTTPS://FORM URL so make sure to change it to HTTPS://WWW to avoid getting back the issue with Mcafee. 

    If the iframe gives you more issues, I would recommend creating a thank you page in your website and use it as the thank you URL in the form. 

    https://www.jotform.com/help/38-Redirecting-Users-to-a-Different-Page 

  • Profile Image
    meyermichele
    Answered on August 07, 2016 at 11:42 AM

    The form does not work on my website with the IFrame coding so I implemented your suggestion of redirecting to a new page.  I would have preferred to have the message working properly on the contact page but this works too and is definitely better than the white screen.  All seems to be working fine now so hopefully we are all set.  Thank you for your help!

  • Profile Image
    Welvin
    Answered on August 07, 2016 at 12:33 PM

    You're welcome. Please feel free to contact us back if you need help with anything else. We are always glad to be of assistance!

    I will further investigate the thank you page issue when using the default embed method and when changing the URL. The form should suppose to scroll, maybe because of your WP theme. I'll let you know if I have found something.